Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to install NIFI 1.0 as ambari service.

Highlighted

Unable to install NIFI 1.0 as ambari service.

Explorer

I was trying to install NIFI as ambari service on HDP 2.4, following this post - https://github.com/abajwa-hw/ambari-nifi-service

On installation page it gives following message -

8461-2.png

Once I select this service and click on install it throws below error –

8462-1.png

2 REPLIES 2
Highlighted

Re: Unable to install NIFI 1.0 as ambari service.

Hi Ankit, there is now official support available for NiFi as part of the HDF stack. Take a look here: http://hortonworks.com/products/data-center/hdf/ The previous demo service was an unsupported community effort which may not get further updates. Though, from what I know, the initial Ambari service and HDF support were driven by the same people. E.g. HDF will greatly simplify NiFi cluster security setup among other things.

Highlighted

Re: Unable to install NIFI 1.0 as ambari service.

Super Guru

You want to install HDF on a separate cluster as it has it's own Ambari. Do not mix them.

http://docs.hortonworks.com/HDPDocuments/HDF2/HDF-2.0.0/bk_ambari-installation/content/ch_installing...

Don't have an account?
Coming from Hortonworks? Activate your account here