Support Questions
Find answers, ask questions, and share your expertise

Unable to install the HDP from Ambari



I am not able to install the HDP from ambari. below the failed logs. Ccan some one help on this.

getting the error status like on ambari status page"

Warnings encountered" "

Failures encountered"


Traceback (most recent call last): File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/", line 37, in <module> BeforeInstallHook().execute() File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/", line 219, in execute method(env) File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/", line 34, in hook install_packages() File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/", line 32, in install_packages Package(packages) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 154, in __init__ File "/usr/lib/python2.6/site-packages/resource_management/core/", line 158, in run self.run_action(resource, action) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 121, in run_action provider_action() File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/", line 49, in action_install self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos) File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/", line 49, in install_package shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput()) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 70, in inner result = function(command, **kwargs) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 92, in checked_call tries=tries, try_sleep=try_sleep) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 140, in _call_wrapper result = _call(command, **kwargs_copy) File "/usr/lib/python2.6/site-packages/resource_management/core/", line 291, in _call raise Fail(err_msg) resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install hdp-select' returned 1. Error: Nothing to do


Super Mentor

@Balaji Vemula

1. Can you please verify the repo files "/etc/yum.repos.d/HDP.repo" and make sure that you are using the correct binaries i,e no mismatch with OS.

# ls -l /etc/yum.repos.d/
# cat /etc/yum.repos.d/HDP.repo

2. What is the output of "hdp-select" you are getting. Please run the "hdp-select" command to those hosts where it is failing to see which version does it show.

# hdp-select
# rpm -qa | grep hdp-select

3. Can you please confirm if you are planning to install a fresh HDP cluster on hosts where you already have another version of packages installed? OR are you planning to perform an HDP upgrade ?

4. If you are planning to create a fresh cluster and the cluster nodes aready have some other version of HDP packages installed in it then you might want to refer to the following link which talks about an ambari utility ""


NOTE: (please read carefully about as it can delete your previously existing HDP data completely) this is useful only when you are not starting with a set of clean machines then you can refer to the above mentioned link and the guidelines to clean the machines. The clean-up essentially removes prior installation of a Hadoop stack and/or Ambari.



Jay, Thanks for your quick reponse.Please find the attached output

Super Mentor

@Balaji Vemula

From the output we see that the HDP version "" is already installed on your ambari server Host. Which will cause conflict because you are planning to install a new fresh HDP cluster.

So in that case i will suggest you to run the Host cleanup script "" to clean older installation and then freshly setup the cluster. As your other nodes does not have any HDP package already installed but only the Ambari host seems to have existing HDP packages.


# python /usr/lib/python2.6/site-packages/ambari_agent/ --silent --skip=users
# python /usr/lib/python2.6/site-packages/ambari_agent/ --skip=users
# python /usr/lib/python2.6/site-packages/ambari_agent/

Or else you can also manually uninstall those unwanted HDP packages from Ambari Server host as mentioned in :


Thank you Jay SenSharma for your help. now i able to install the hdp on my ambari server but i couldn't able to install it on ohter nodes. Getting error messgae as attached.Please help.


Super Mentor

@Balaji Vemula

Based on the following error , i guess those nodes already has some HDP packages installed in them.

resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install 'hadoop_2_4_*-yarn'' returned 1. Error: Nothing to do


You can verify if any hadoop package is already installed on the 3 problematic hosts or not by running the following command:

# yum info hadoop*-yarn
# yum info hadoop*


If you see that some packages are already installed there then it is better to clean those first using the "" On All Hosts and then retry installing cluster from Ambari.


Jay SenSharma, Thank you so much. I ran the script in all the nodes and checked the info about the packages, not found the info still i am getting the same error on ambari page.


Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.