Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Unable to save when using Advance setting in NiFi 1.0.0 UpdateAttribute processor

avatar
Expert Contributor

I seem to have encountered an error in NiFi-1.0.0 where I am unable to save when using the Advanced UI setting in the Update Attribute Processor and is giving the following error:

Unable to save UpdateAttribute[id=] criteria: org.apache.nifi.cluster.manager.exception.IllegalClusterStateException: Node is unable to fulfill this request due to: Transaction is already in progress.

This error seems to be a bug from the NiFi-1.0.0 version and I wanted to verify if there is a patch for this bug?

1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
5 REPLIES 5

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Expert Contributor

Hi @Yolanda M. Davis , thanks for the link. Do you know where I could find the instructions to add a patch to NiFi?

avatar
Expert Contributor

If you are using NiFi 1.0.0 with HDF 2.0 there is a plan for another release (e.g. v. 2.0.1) that should include this fix. In the meantime if you are using NiFi outside of HDF the current course of action is to download the actual NiFi source and build it separately (unfortunately there isn't a specific patch file to apply to an existing installation). Here is the quick start guide that has information on building from source.

I hope this helps and thank you for highlighting this issue.

avatar
Expert Contributor

ok, thanks for all the help!

avatar
Rising Star

Hi,

So what is the workaround if I dont want to update my NiFi version. Can we use any other processor for this rule/condition stuff?