Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to start Accumulo service on HDP-3.1

Highlighted

Unable to start Accumulo service on HDP-3.1

New Contributor

Hello,

I have installed Accumulo on HDP-3.1 and when I try to start the service using Ambari it gives the below error

stderr

Python script has been killed due to timeout after waiting 600 secs

stdout

2019-06-06 10:37:25,811 - Skipping Execute['cat /var/lib/ambari-agent/tmp/pass | ACCUMULO_CONF_DIR=/usr/hdp/current/accumulo-master/conf/server /usr/hdp/current/accumulo-client/bin/accumulo init --instance-name hdp-accumulo-instance --clear-instance-name >/var/log/accumulo/accumulo-init.out 2>/var/log/accumulo/accumulo-init.err'] due to not_if
2019-06-06 10:37:25,811 - File['/var/lib/ambari-agent/tmp/pass'] {'action': ['delete']}
2019-06-06 10:37:25,812 - Deleting File['/var/lib/ambari-agent/tmp/pass']
2019-06-06 10:37:25,812 - Directory['/var/lib/accumulo'] {'owner': 'accumulo', 'group': 'hadoop', 'recursive_ownership': True}
2019-06-06 10:37:25,813 - Execute['ACCUMULO_CONF_DIR=/usr/hdp/current/accumulo-master/conf/server /usr/hdp/current/accumulo-client/bin/accumulo org.apache.accumulo.master.state.SetGoalState NORMAL'] {'not_if': "ambari-sudo.sh su accumulo -l -s /bin/bash -c 'ls /var/run/accumulo/accumulo-accumulo-master.pid >/dev/null 2>&1 && ps `cat /var/run/accumulo/accumulo-accumulo-master.pid` >/dev/null 2>&1'", 'user': 'accumulo'}

Command failed after 1 tries

I suspect its not the timeout issue that is causing this. When I extracted the command from Ambari and ran on the host running Accumulo master, getting the below message. Its strange that I don't see anything logged under /var/log/accumulo/. I have tried restarting HDFS & ZK just to tick the box but still no difference.

This is my first time experience with Accumulo. Anyone seen this or can offer any help is highly appreciated. This cluster is not Kerberized.

[root@accumulo-m0 ~]# su - accumulo 
Last login: Thu Jun  6 10:17:12 UTC 2019 on pts/0
-bash-4.2$ /usr/hdp/current/accumulo-client/bin/accumulo org.apache.accumulo.master.state.SetGoalState NORMAL
2019-06-06 10:23:51,748 [server.Accumulo] INFO : Attempting to talk to zookeeper
2019-06-06 10:23:51,883 [server.Accumulo] INFO : Waiting for accumulo to be initialized
2019-06-06 10:23:52,885 [server.Accumulo] INFO : Waiting for accumulo to be initialized

Thanks,

Techabong

Don't have an account?
Coming from Hortonworks? Activate your account here