Support Questions
Find answers, ask questions, and share your expertise

Unable to start ambari-server

Highlighted

Unable to start ambari-server

New Contributor

I am unable to start my ambari-server. Below I have mentioned the error log.

ambari-server start

Using python /usr/bin/python Starting ambari-server Ambari Server running with administrator privileges. Organizing resource files at /var/lib/ambari-server/resources... Ambari database consistency check started... Server PID at: /var/run/ambari-server/ambari-server.pid Server out at: /var/log/ambari-server/ambari-server.out Server log at: /var/log/ambari-server/ambari-server.log Waiting for server start.........Unable to determine server PID. Retrying... ......Unable to determine server PID. Retrying... ......Unable to determine server PID. Retrying... ERROR: Exiting with exit code -1. REASON: Ambari Server java process died with exitcode 1. Check /var/log/ambari-server/ambari-server.out for more information.

cat /var/log/ambari-server/ambari-server.out

Exception in thread "main" java.lang.RuntimeException: java.lang.Exception at org.apache.ambari.server.state.stack.OsFamily.init(OsFamily.java:92) at org.apache.ambari.server.state.stack.OsFamily.<init>(OsFamily.java:66) at org.apache.ambari.server.controller.ControllerModule.<init>(ControllerModule.java:199) at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:984) Caused by: java.lang.Exception at org.apache.ambari.server.state.stack.OsFamily.init(OsFamily.java:82)

Can you please help me with this error.

3 REPLIES 3
Highlighted

Re: Unable to start ambari-server

Mentor

@Mohammed Ashik

Please could you give some details. Is the databse up and running?

- Operating System
- Ambari version
- HDP version
- Fresh Install or Upgrade.

Thank you

Highlighted

Re: Unable to start ambari-server

New Contributor

Hi @Geoffrey Shelton Okot,

Operating System : CentOS 6.6

Ambari Version = 2.5.0.3

HDP Version = 2.3

Upgrading from 2.2*

Database is up running..

After upgrade it was working fine. I have installed urllib python package in my system and ambari-agent in the edge node stopped working due to module conflict. So i removed urllib package and ambari-agent started working, after restart I tried to start the server and those above mentioned error occurred.

Thanks

Ashik

Highlighted

Re: Unable to start ambari-server

Mentor

@Mohammed Ashik

Glad it worked for you ....hope you gave me a reward for that :-)