Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to uninstall hadoop due to failed dependencies

Unable to uninstall hadoop due to failed dependencies

Contributor

Hi,

 

I am trying to uninstall hadoop manually that is installed by using rpms, but getting failed due to dependencies error.

 

PFB the logs.

 

rpm -e hadoop-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64
error: Failed dependencies:
libhadoop.so.1.0.0()(64bit) is needed by (installed) hadoop-hdfs-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64
libhadoop.so.1.0.0()(64bit) is needed by (installed) hadoop-yarn-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64
hadoop is needed by (installed) parquet-format-2.1.0+cdh5.3.2+8-1.cdh5.3.2.p0.17.el6.noarch
hadoop is needed by (installed) parquet-1.5.0+cdh5.3.2+62-1.cdh5.3.2.p0.17.el6.noarch
hadoop = 2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6 is needed by (installed) hadoop-hdfs-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64
hadoop = 2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6 is needed by (installed) hadoop-yarn-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64
hadoop = 2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6 is needed by (installed) hadoop-mapreduce-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64

 

Please help me to uninstall the hadoop.

 

Thanks,

Priya

2 REPLIES 2

Re: Unable to uninstall hadoop due to failed dependencies

Super Guru

@cdhhadoop,

 

This appears to be more of an "rpm" usage question than a hadoop issue.  To skip dependeny checking in "rpm -e", use the --nodeps option:

 

# rpm -e hadoop-2.5.0+cdh5.3.2+813-1.cdh5.3.2.p0.17.el6.x86_64 --nodeps

 

Ben

Highlighted

Re: Unable to uninstall hadoop due to failed dependencies

Contributor
Thanks for reply. One more query, do I need to uninstall all the files and directories too after uninstall?

Thanks,
Priya