Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Unable to upgrade from HDP 2.3.4.0 to 2.3.4.7

avatar
Expert Contributor

I am trying to upgrade HDP 2.3.4.0 to HDP 2.3.4.7 version but I am getting below error message.

2017-01-07 19:49:31,961 - Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=HDP-*' --enablerepo=HDP-2.3.4.7,HDP-UTILS-2.3.4.7 rpcbind' returned 1. Transaction check error: package rpcbind-0.2.0-38.el7.x86_64 is already installed

Please find the attachement(error_log1.txt) for error summary. I have registered the target version but while performing package installation, I am facing this issue. Please find the attached screen shots for your reference.

Could you please help on this.

Thank you.

BR, Sampath

error-log1.txt

11222-stack-vesions.png

11224-version-status.png

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
2 REPLIES 2

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Expert Contributor

Thanks for your message.

Ambari version : 2.2.0.0.

I have removed the rpcbind-0.2.0-38.el7.x86_64 package and tried to upgrade the HDP and it worked for me.