Support Questions
Find answers, ask questions, and share your expertise

Upgrade HDP 2.5.0 to 2.5.3

Hello Everyone,

I starded this morning, upgraded HDP 2.5.0 to 2.5.3 with ambari 2.4 but i have 2 errors when i begin install new repository. I want to do Express Upgrade and i resgister new version with ambari. this is picture describe my error run.

11615-hdp-upgrade.png

Can you help me please?

What is the best way to ugrade HDP with ambari?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Upgrade HDP 2.5.0 to 2.5.3

Super Mentor

@Baruch AMOUSSOU DJANGBAN

In addition to previous comments, When you are registering a new HDP version then at that time are you specifying the "Build Version" for the HDP 2.5.3 ?

Example: 2.5.3.0-37

As per the http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-installation/content/hdp_25_reposi...

The Version Definition file has this info: http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.5.3.0/HDP-2.5.3.0-37.xml

- Also regarding one of your query "i don't understand very well HDP-major.minor concept" ... the following links provides this information in very detail:

https://community.hortonworks.com/questions/41422/question-on-hdp-versioning.html

.

View solution in original post

16 REPLIES 16

Re: Upgrade HDP 2.5.0 to 2.5.3

Have your servers access to the Internet to get access to the repository? Did you use a local repository? Before performing the upgrade, the new version should be installed on all hosts, and the installation must have failed on one host, hence the error. You can try to reinstall the version on all hosts (basically it will install the stack in /usr/hdp).

Re: Upgrade HDP 2.5.0 to 2.5.3

Thanks @Pierre Villard

I use local repository. i havn't acces internet. I thinks the problem is when i register new version in ambari. i don't understand very well HDP-major.minor concept. That 's how i fill this fields. Is it correct ??

11616-hdp-ugrapde22.png

Re: Upgrade HDP 2.5.0 to 2.5.3

Super Guru

@Baruch AMOUSSOU DJANGBAN

Please login to your Ambari server as root user --> Goto /etc/yum.repos.d/ --> Find any conflicting repositories for HDP-2.5.3 --> Maybe move all HDP-2.5.3 repos to some other location (apart from /etc/yum.repos.d) --> start over the upgrade again --> Ambari should register repository again

Re: Upgrade HDP 2.5.0 to 2.5.3

Thanks @Kuldeep Kulkarni

I will try it.

😉

Re: Upgrade HDP 2.5.0 to 2.5.3

Super Guru

@Baruch AMOUSSOU DJANGBAN - Sure. Please let us know the results 🙂 If it resolves your issue then please accept my answer.

Re: Upgrade HDP 2.5.0 to 2.5.3

i try it. It's dont work. i got this error

11617-hdppppp.png

thanks

Re: Upgrade HDP 2.5.0 to 2.5.3

Super Mentor

@Baruch AMOUSSOU DJANGBAN

In addition to previous comments, When you are registering a new HDP version then at that time are you specifying the "Build Version" for the HDP 2.5.3 ?

Example: 2.5.3.0-37

As per the http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-installation/content/hdp_25_reposi...

The Version Definition file has this info: http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.5.3.0/HDP-2.5.3.0-37.xml

- Also regarding one of your query "i don't understand very well HDP-major.minor concept" ... the following links provides this information in very detail:

https://community.hortonworks.com/questions/41422/question-on-hdp-versioning.html

.

View solution in original post

Re: Upgrade HDP 2.5.0 to 2.5.3

Thanks @Jay SenSharma

I understand now. But i try all things, i don't resolve my error. I got this error. It's can find hadoop_2_5_3_0_37. I don't understand why.

11629-test.png

Re: Upgrade HDP 2.5.0 to 2.5.3

I wan't to complete by this information. I don't have acces to internet. This system is receiving updates from Red Hat Satellite.