Support Questions
Find answers, ask questions, and share your expertise

Upgrade Zeppelin to 0.7 in HDP 2.5

Upgrade Zeppelin to 0.7 in HDP 2.5

New Contributor

Hi,

We have just started using HDP 2.5. We would like to upgrade our Zepplin version from 0.6 (installed along with HDP2.5) to 0.7 since we want to execute paragraph in a synchronous way.

Upgrading the entire HDP to 2.6 is an overkill for us since we have to backup all the existing data.

Please let me know if it is possible to upgrade Zeppelin alone (or) any alternatives solutions

11 REPLIES 11

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

Guru

@Dharanidhar Ch, Please follow instructions mentioned in below article.

https://zeppelin.apache.org/docs/0.7.0/install/upgrade.html

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

New Contributor

@yvora

Thanks for the reply. We would like to manage Zeppelin from Ambari similar to rest of the HDP services

Can u please confirm if this upgrade would update the version of Zeppelin in Ambari

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

Guru

@Dharanidhar Ch, Since Zeppelin is upgraded manually, the version of Zeppelin in ambari wont change.

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

New Contributor

Hi @yvora, Thanks for the reply. I was able to install zeppelin as a separate service.

Is it possible to let HDP Ambari pick this service instead of the older Zeppelin ?

Can you please tell me on what basis Ambari picks up a service ? Any database/property configuration ?

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

Guru

@Dharanidhar Ch, Ambari has concept of stack definition which figures out which HDP stack will be picked up. Refer to below articles for details.

Reference: https://cwiki.apache.org/confluence/display/AMBARI/How-To+Define+Stacks+and+Services

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

Contributor

Hi @Dharanidhar Ch, I would like also to upgrade Zeppelin in HDP 2.5. Did you try that?

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

New Contributor

Hi @Jose Molero, I have installed Zeppelin 0.7 as an independent service since Ambari would not be able to recoginize this as an upgrade.

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

Contributor

Hi @Dharanidhar Ch . Ok, are you using Zeppelin 0.7 with spark (1 or 2) and livy? Is working for you?

Thanks

Re: Upgrade Zeppelin to 0.7 in HDP 2.5

New Contributor

@Jose Molero, we are using spark 2 and its working good for us.