Support Questions
Find answers, ask questions, and share your expertise

Upgrade jdk in kerberized cluster (ambari)

Highlighted

Upgrade jdk in kerberized cluster (ambari)

New Contributor

I am trying to upgrade my jdk1.8.0_172 to jdk1.8.0_241 in a kerberized cluster. I have followed this doc tuto upgrade jdk

The problem is, when I restared the cluster, some services installed in the ambari server host, won't start and failled with an error of : failled to connect
I know that the doc is not for kerberized clusters, but I already copied my "/usr/jdk64/OLD/jdk1.8.0_172/jre/lib/security/jssecacerts" file into the new one. Even though, I still have the same problem, so I guess I am missing something here.

Does anyone know what is causing this problem ?

NB : I am runing DP_VERSION="3.1.5.0" and AMBARI_VERSION="2.7.5.0"
Thanks