Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Upgrade to 5.7 fails while activation phase

Upgrade to 5.7 fails while activation phase

New Contributor

I was upgrading my instance from 5.2 to CDH 5.7 from UI and it fails while activation part.

I tried to look for parcel and it is seem it doesn't exist there.

Now my whole instance is down. Can anyone quickly help me to sort out this issue? what can be done to upgrade to 5.7.

 

  • Error when distributing to <the server name> : Src file /opt/cloudera/parcels/.flood/CDH-5.7.0-1.cdh5.7.0.p0.45-el7.parcel/CDH-5.7.0-1.cdh5.7.0.p0.45-el7.parcel does not exist.

 

4 REPLIES 4

Re: Upgrade to 5.7 fails while activation phase

Cloudera Employee

The parcel state in the UI should currently be "distributed".  Please try to "Remove From Hosts" and "distribute" again.  The real issue here is occuring on the agent, and thus a proper understanding of this issue requires analysis of the agent logs.

Re: Upgrade to 5.7 fails while activation phase

New Contributor

Thank you so much for your reply.

 

From error it is already distributed. Problem came while activation. Please check the attached image.

Also as per the image you can see it doesn't have option of "Remove from Host".

The other parcel (older 5.2) That I had does have option of remove from host. 

Also please let me know what logs (the location from where i should fetch) to share with u.

 

http://i.imgur.com/wYh62xV.png

 

 

Re: Upgrade to 5.7 fails while activation phase

Explorer

Were you able to resolve the issue? I've seen this too when distributing a new parcel onto CDH 5.7.0. 

Highlighted

Re: Upgrade to 5.7 fails while activation phase

New Contributor

I ran into this issue when installing our own custom parcel the other day.  What it came down to was restarting the Cloudera-scm-agent on the host it was complaining about.  I believe that regenerates the .flood directory.  Actually, I deleted the entire .flood directory and did a:

 

service cloudera-scm-agent restart

 

After that, I was able to redistribute and activate the parcel with no problems.