Support Questions
Find answers, ask questions, and share your expertise

Upgrading HDP from 2.3 to 2.4 -error: UPGRADE_TYPE_NON_ROLLING

Expert Contributor

I have a multicluster that Ive decided to upgrade to 2.4 Upgrade of Ambari to 2.2 went well. When I was upgrading (express upgrade) the HDP I got this warning (python error):

UPGRADE_TYPE_NON_ROLLING

on these steps:

Prepare HDFS

Wait to leave Safemode

Update stack to 2.4.0.0.-169

Execute HDFS Finalize

I clicked Ignore and Proceed on all of them and the installation was a success.

Can anyone explain me what is this all about? what went wrong?

1 REPLY 1

Re: Upgrading HDP from 2.3 to 2.4 -error: UPGRADE_TYPE_NON_ROLLING

Super Guru