Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Use Hue with Impala in Docker

Highlighted

Use Hue with Impala in Docker

New Contributor

Hello,

 

I have a few hadoop services running locally in my pc with Docker. I have hdfs and the impala-shell running through the command line without any issues but I am unable to make it run in Hue. 

 

First of all, Hue is connecting to the HDFS filesystem and I can navigate, upload or delete files in hdfs. I don't have the hive-server2 running but the Impalad is running properly and Hue is configured to connect to it to the port 21050 (the same port that appears when I connect through impala-shell).

 

When I open the hue with Impala, I get the following errors: 

"Ignoring invalid configuration option: idle_session_timeout"

 

"Bad status for request TOpenSessionReq(username=u'hue', password=None, client_protocol=6, configuration={'idle_session_timeout': '3600'}): TOpenSessionResp(status=TStatus(errorCode=None, errorMessage='Ignoring invalid configuration option: idle_session_timeout', sqlState='HY000', infoMessages=None, statusCode=3), sessionHandle=TSessionHandle(sessionId=THandleIdentifier(secret='\xc3h\x04\x1a\xde\xd9Ab\xb9b\x0f\xdf\xfe\x83\xe3\x93', guid='\x9e\x98\xe7\xa2\x8c\xa0Jg\x97%\xbaF\x1c\x87\t\x04')), configuration=None, serverProtocolVersion=4)"

 

This is how my hue.ini looks like:

 

 

[hadoop]
 
  [[hdfs_clusters]]
 
    [[[default]]]
 
      # Enter the filesystem uri
      fs_defaultfs=hdfs://hadoop:8020
 
      # Use WebHdfs/HttpFs as the communication mechanism.
      # Domain should be the NameNode or HttpFs host.
      webhdfs_url=http://hadoop:50070/webhdfs/v1

[beeswax]
 
  # Host where HiveServer2 is running.
  hive_server_host=hadoop.ent.com
  
  
[impala]
 
  # Host of the Impala Server (one of the Impalad)
  server_host=hadoop
  server_port=21050

#[desktop]
#app_blacklist=beeswax,security,metastore,spark,indexer,spark,pig,hbase,sqoop,jobbrowser,rdbms,jobsub,zookeeper

[desktop]
	[[auth]]
	# A negative number means that idle sessions will not be timed out.
	idle_session_timeout=-1

I have been going on with this issue for days and I would really like to use the Hue instead of the Impala-shell to make my life easier. Is it mandatory to have the Hive-server2 running to run Impala queries?

1 REPLY 1

Re: Use Hue with Impala in Docker

Super Collaborator

First :

- Why do you suspect that Hiveserver2 need to be up and running for impala query to works ? Did you observe that when running Hiveserver2 impala queries worked ?

By the way, Hivemetastore is running right ?

 

- Second : You should go look at hue server log files. You should see a better error.

 

regards,

mathieu