Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Users and Groups missing on the host

Users and Groups missing on the host

New Contributor

This is a fresh install of CDH 4 (latest release) and Cloudera Manager.  The Host Inspector reports the following after several attempts at installing and then trying to upgrade.  I only have 1 host as this is a test environment.  Any ideas?  This is on CentOS 6.4 running in Hyper-V.

 

 Inspector ran on all 1 hosts.
 Individual hosts resolved their own hostnames correctly.
 No errors were found while looking for conflicting init scripts.
 No errors were found while checking /etc/hosts.
 All hosts resolved localhost to 127.0.0.1.
 All hosts checked resolved each other's hostnames correctly.
 Host clocks are approximately in sync (within ten minutes).
 Host time zones are consistent across the cluster.
 The user hdfs is missing on the following hosts:
 The user mapred is missing on the following hosts:
 The user zookeeper is missing on the following hosts:
 The user oozie is missing on the following hosts:
 The user hbase is missing on the following hosts:
 The user hue is missing on the following hosts:
 The group hdfs is missing on the following hosts:
 The group mapred is missing on the following hosts:
 The group zookeeper is missing on the following hosts:
 The group oozie is missing on the following hosts:
 The group hbase is missing on the following hosts:
 The group hue is missing on the following hosts:
 The group hadoop is missing on the following hosts:
 No kernel versions that are known to be bad are running.
 No performance concerns with Transparent Huge Pages settings.
 1 hosts are reporting with NONE CDH version
 All checked hosts are running the same version of components.
 All managed hosts have consistent versions of Java.
 All checked Cloudera Management Daemons versions are consistent with the server.
 All checked Cloudera Management Agents versions are consistent with the server.

Version Summary

HostsComponent Version CDH Version
Group 1 (Unavailable)
Hadoop
ImpalaUnavailableNot installed or path incorrect
Yarn (CDH4 only)UnavailableNot installed or path incorrect
HDFS (CDH4 only)UnavailableNot installed or path incorrect
Hue PluginsUnavailableNot installed or path incorrect
Sqoop2 (CDH4 only)UnavailableNot installed or path incorrect
MapReduce 2 (CDH4 only)UnavailableNot installed or path incorrect
HBaseUnavailableNot installed or path incorrect
HCatalog (CDH4 only)UnavailableNot installed or path incorrect
OozieUnavailableNot installed or path incorrect
ZookeeperUnavailableNot installed or path incorrect
HueUnavailableNot installed or path incorrect
MapReduce 1 (CDH4 only)UnavailableNot installed or path incorrect
PigUnavailableNot installed or path incorrect
HttpFS (CDH4 only)UnavailableNot installed or path incorrect
HadoopUnavailableNot installed or path incorrect
HiveUnavailableNot installed or path incorrect
Lily HBase Indexer (CDH4 only)UnavailableNot installed or path incorrect
Solr (CDH4 only)UnavailableNot installed or path incorrect
Flume NGUnavailableNot installed or path incorrect
Javajava version "1.6.0_31" Java(TM) SE Runtime Environment (build 1.6.0_31-b04) Java HotSpot(TM) 64-Bit Server VM (build 20.6-b01, mixed mode)Not applicable
Cloudera Manager Agent4.7.3Not applicable
1 REPLY 1
Highlighted

Re: Users and Groups missing on the host

Explorer

Are you installing as root?  I haven't had this specific problem, but you could just create the users and groups manually and re-run the inspector.  The problem I kept having was CM would not chown the directories correctly, and the HDFS service for example would fail to start because the DFS directory was owned by root instead of the hdfs user.