Support Questions
Find answers, ask questions, and share your expertise

VM CDH5 services does not start


Hi All
After installing image with CDH5 everytjhing worked OK.
But in 3 days http://quickstart.cloudera:7180/cmf/home#
some services

Some warnings were before but services started OK before.
Re-strat VM and services does Not help.


Current warnings :
Cloudera QuickStart

ZooKeeper: Service zookeeper has 1 Server. Cloudera suggests at least 3 Servers for ZooKeeper. Suppress...
HDFS: Service hdfs has 1 DataNode. Cloudera suggests at least 3 DataNodes for HDFS. Suppress...
HDFS: Java Heap Size of NameNode in Bytes Suppress...
Java Heap Size of NameNode in Bytes is recommended to be at least 1GB for every million HDFS blocks. Suggested minimum value: 4294967296
quickstart.cloudera: Memory Overcommit Validation Threshold Suppress...
Memory on host quickstart.cloudera is overcommitted. The total memory allocation is 18.2 GiB bytes but there are only 10.1 GiB bytes of RAM (2.0 GiB bytes of which are reserved for the system). Visit the Resources tab on the Host page for allocation details. Reconfigure the roles on the host to lower the overall memory allocation. Note: Java maximum heap sizes are multiplied by 1.3 to approximate JVM overhead.


2 Screens  attached

ps I tried to see logs - but don't know what to search there and what to do next even if I find error messages in log/

Any ideas welcome Err_001.JPGerr_002.JPG



Bad : Canary test failed to create file in directory /tmp/.cloudera_health_monitoring_canary_files.
A failure of this health test may indicate that the cluster is failing to satisfy basic client requests correctly or in a timely fashion.
Check the status of the NameNode and other service-level health tests.


http://quickstart.cloudera:7180/cmf/services/8/instances/15/checkDetails?timestamp=1482159881630¤tMo... Bad : This NameNode was in safe mode.


Try to run

> hdfs/ ["dfsadmin","-fs","hdfs://quickstart.cloudera:8020","-safemode","leave"]
The NameNode successfully left Safemode.

But problem still exist




Rising Star



Thanks for reaching out on this. 


To start this out, try starting the non-running services in cloudera manager, using the order specified in the documentation. While doing this, please take screenshots of any errors that appear in the dialogue boxes. If the service is already running, move on to the next one. Let me know what happens, and we can go from there. 




I am also similar issue. I followed the sequence mentioned as below

1) ZooKeeper
3) HttpFS
4) MRv1
5) YARN (MR2)
6) HBase
7) Hive
😎 Oozie
9) Flume 1.x
10) Sqoop
11) Hue


This does not resolve the problem. Even after starting, services are going down.