Support Questions
Find answers, ask questions, and share your expertise

Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

Solved Go to solution
Highlighted

Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

Contributor

According to Hortonworks Support Matrix https://supportmatrix.hortonworks.com/, supported versions of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4 are 9.4, 9.3 and "9.1.13+". 9.2 is not included.

But the yum base repo for RHEL 7.4 includes PostgreSQL 9.2.23.

Do I have to install PostgreSQL 9.3 or 9.4 for this environment? Or, PostgreSQL 9.2.x is also okay? "9.1.13+" includes 9.2.x?

Of course, I know PostgreSQL 9.3 or 9.4 is easy to install by a procedure introduced in this page https://www.postgresql.org/download/linux/redhat/, but if 9.2.x is okay, I want to use it.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

@Takefumi Oide

I think for Ambari 2.6.x Postgres 6.2 is supported version - Supportmatrix has a BUG and will review that and correct in next couple of days - for now you can continue using 6.2

Let me know any questions on that.

View solution in original post

5 REPLIES 5

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

Hi

Always use the newer version, less bugs, more security and functionality.

Even if it is not in the matrix, I use postgresl 9.5 for ambari, hive, ranger, oozie, hue.

Keep in mind that if you plan to upgrade to HDP 3 and ambari 2.7 you have to upgrade to postgresql 10.2.

Regards.

Highlighted

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

@Takefumi Oide

When you install ambari it will install its own appropriate version of Postgres. You do not have to install postgres separately. If you do want to control the version of postgres, you can complete your own Postgres install and setup advanced database configuration during ambari-server setup command.

As always, please choose ACCEPT if this answer helps.

Highlighted

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

@Takefumi Oide

I think for Ambari 2.6.x Postgres 6.2 is supported version - Supportmatrix has a BUG and will review that and correct in next couple of days - for now you can continue using 6.2

Let me know any questions on that.

View solution in original post

Highlighted

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

Contributor

Thank you all.

In my case, using "supported" versions is necessary.

As far as I know, when installing Ambari Server, PostgreSQL is usually installed together from "base" yum repository which belongs to OS. Not from a repo of Ambari's yum repo. That is why I wrote "the yum base repo for RHEL 7.4 includes PostgreSQL 9.2.23".

@apappu wrote "Postgres 6.2", but I thought this is a typo of "Postgres 9.2", right?

And I hope Support Matrix will be fixed soon.

Highlighted

Re: Version of PostgreSQL for Ambari 2.6.2.2 + HDP 2.6.5 on RHEL 7.4

amarnath reddy pappu and Steven Matison while doing ambari upgrade 2.7.3 from 2.6.2 do we need to explicitly upgraded postgres from 9.2 to 10.2 or ambari will take care of postgres upgrade?