Support Questions

Find answers, ask questions, and share your expertise

Very Strange: Nifi Flow does not have Input ports

Rising Star

Please, kindly help.

I am trying to do Minifi - Nifi s2s communication.

So, i was trying to generate a flow file(to use for minifi) on one of Secured Nifi cluster nodes.

- i dropped an input port on the root canvas & connected it to putfile processor

- i created a process group. I dropped tailfile processor & Remote Process Group processor inside it.

- I configured RPG with the url of the root canvas

I don't actually know what i am doing wrong because all my configurations seems to be good.

# Site to Site properties
nifi.remote.input.host=masternode
nifi.remote.input.secure=true
nifi.remote.input.socket.port=10000
nifi.remote.input.http.enabled=true
nifi.remote.input.http.transaction.ttl=30 sec
nifi.remote.contents.cache.expiration=30 secs

 

Below are the the pics.

rpg_settings.png

tail_rpg_conn_error.pngpg_rpg.pngmain-flow.png

 

1 ACCEPTED SOLUTION

Rising Star

Thanks to everyone for your kind help.

Eventually, i got to know that the problem is with the access policy.

I got the clue from here:

https://bryanbende.com/development/2016/08/30/apache-nifi-1.0.0-secure-site-to-site 

 

Thank you all.

View solution in original post

1 REPLY 1

Rising Star

Thanks to everyone for your kind help.

Eventually, i got to know that the problem is with the access policy.

I got the clue from here:

https://bryanbende.com/development/2016/08/30/apache-nifi-1.0.0-secure-site-to-site 

 

Thank you all.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.