Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the

WARN :Unable to load native-hadoop library for your platform... using builtin-java classes where app

Highlighted

WARN :Unable to load native-hadoop library for your platform... using builtin-java classes where app

New Contributor

questions WARN :Unable to load native-hadoop library for your platform... using builtin-java classes where app

 

my local machine is i386

and i try to download hadoop-2.3.0-cdh5.0.2-src.tar.gz and do

 

# mvn package -Pdist,native -Dskiptests -Dtar
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-project:pom:2.3.0-cdh5.0.2
[WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-enforcer-plugin @ line 1009, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-project-dist:pom:2.3.0-cdh5.0.2
[WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-enforcer-plugin @ org.apache.hadoop:hadoop-project:2.3.0-cdh5.0.2, /home/hadoop/soft/hadoop-2.3.0-cdh5.0.2/hadoop-project/pom.xml, line 1009, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-auth:jar:2.3.0-cdh5.0.2
[WARNING] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.mortbay.jetty:jetty-util:jar -> duplicate declaration of version (?) @ line 60, column 17
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-common:jar:2.3.0-cdh5.0.2
[WARNING] 'build.plugins.plugin.(groupId:artifactId)' must be unique but found duplicate declaration of plugin org.apache.maven.plugins:maven-surefire-plugin @ line 480, column 15
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]

 

Above error influence compile operation,who can  help me please,thanks 

1 REPLY 1

Re: WARN :Unable to load native-hadoop library for your platform... using builtin-java classes where

Explorer

Well i guess you need to be more precise about that. i386 is an architecture not an OS. So which OS you are trying to build for? 

 

The Maven warnings there will not prevent the build. If your build is failing, there must be another error down below. To build Hadoop from source including the native libs you need a bit more then the usual setup.

 

Read the BUILDING.txt which gets extracted to see all the preconditions. 

This article was very helpful to me to get it working:

http://vichargrave.com/create-a-hadoop-build-and-development-environment-for-hadoop/

 

BR

Marc