Support Questions
Find answers, ask questions, and share your expertise

What ambari-server version is complatible with splicemachine 2.6?

New Contributor

I want install splicemachine ambari service, but I get conficts with package ambari-server.

yum install splicemachine_ambari_service Loaded plugins: langpacks Resolving Dependencies --> Running transaction check ---> Package splicemachine_ambari_service.noarch 0:hdp2.6.3.2.7.0.1815.p0.58-1 will be installed --> Finished Dependency Resolution Dependencies Resolved ===================================================================================================================================================================================================== Package Arch Version Repository Size ===================================================================================================================================================================================================== Installing: splicemachine_ambari_service noarch hdp2.6.3.2.7.0.1815.p0.58-1 splicemachine 14 k Transaction Summary ===================================================================================================================================================================================================== Install 1 Package Total size: 14 k Installed size: 40 k Is this ok [y/d/N]: y Downloading packages: Running transaction check Running transaction test Transaction check error: file /var/lib/ambari-server/resources/common-services from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.7.0.0-897.x86_64 file /var/lib/ambari-server/resources/stacks from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.7.0.0-897.x86_64 file /var/lib/ambari-server/resources/stacks/HDP from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.7.0.0-897.x86_64 file /var/lib/ambari-server/resources/stacks/HDP/2.6 from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.7.0.0-897.x86_64 file /var/lib/ambari-server/resources/stacks/HDP/2.6/services from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.7.0.0-897.x86_64

2 REPLIES 2

Super Mentor

@Claudio H

The error indicates that the package "splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch" is causing conflict with the "ambari-server-2.7.0.0-897.x86_64" binaries.

As they both has their own set of common-services and HDP stack

/var/lib/ambari-server/resources/common-services
/var/lib/ambari-server/resources/stacks/HDP/2.6

.

Please note that Ambari 2.7.0.0 is compatible with HDP 3.0 only as per : https://supportmatrix.hortonworks.com/

hence if you want to use the use the "splicemachine_ambari_service" then you should use the older version of Ambari. As from Ambari 2.7 there has been some major changes happened in Ambari specially in terms of common-services and HDP stack structure.

New Contributor

Hi, Jay Kumar SenSharma, Now, i installed ambari-server-2.6.0.0-267.x86_64 but the problem continued

[ root@splicemachine1:/etc/yum.repos.d ] $ yum install splicemachine_ambari_service Loaded plugins: langpacks Resolving Dependencies --> Running transaction check ---> Package splicemachine_ambari_service.noarch 0:hdp2.6.3.2.7.0.1815.p0.58-1 will be installed --> Finished Dependency Resolution Dependencies Resolved ===================================================================================================================================================================================================== Package Arch Version Repository Size ===================================================================================================================================================================================================== Installing: splicemachine_ambari_service noarch hdp2.6.3.2.7.0.1815.p0.58-1 splicemachine 14 k Transaction Summary ===================================================================================================================================================================================================== Install 1 Package Total download size: 14 k Installed size: 40 k Is this ok [y/d/N]: y Downloading packages: No Presto metadata available for splicemachine splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch.rpm | 14 kB 00:00:00 Running transaction check Running transaction test Transaction check error: file /var/lib/ambari-server/resources/common-services from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.6.0.0-267.x86_64 file /var/lib/ambari-server/resources/stacks from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.6.0.0-267.x86_64 file /var/lib/ambari-server/resources/stacks/HDP from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.6.0.0-267.x86_64 file /var/lib/ambari-server/resources/stacks/HDP/2.6 from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.6.0.0-267.x86_64 file /var/lib/ambari-server/resources/stacks/HDP/2.6/services from install of splicemachine_ambari_service-hdp2.6.3.2.7.0.1815.p0.58-1.noarch conflicts with file from package ambari-server-2.6.0.0-267.x86_64

[ root@splicemachine1:/var/lib/ambari-server/resources ] $

[ root@splicemachine1:/var/lib/ambari-server/resources ] $ ls -lrt stacks/HDP

total 48

drwxr-xr-x 4 root root 4096 Sep 5 13:36 2.0.6.GlusterFS

drwxr-xr-x 7 root root 4096 Sep 5 13:36 2.0.6

drwxr-xr-x 4 root root 4096 Sep 5 13:36 2.0

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.1.GlusterFS

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.1

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.2

drwxr-xr-x 4 root root 4096 Sep 5 13:36 2.3.ECS

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.3.GlusterFS

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.3

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.4

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.5

drwxr-xr-x 5 root root 4096 Sep 5 13:36 2.6

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.