Support Questions

Find answers, ask questions, and share your expertise

What is Apache Storm Compatibility?

New Contributor

I tried setting up an Apache Storm Cluster, using Apache Storm 1.0.2 and Zookeeper 3.4.9. Everything worked fine, but I realized that Apache Samoa - What I'm going to use the Cluster for - is only compatible with versions of Apache Storm <1.0.0.

Thus, I downgraded all of the Apache Storm nodes to Apache Storm 0.9.4, but none of the nodes could connect to the Zookeeper. Is Apache Storm 0.9.4 only compatible with older versions of Zookeeper? If so, does anybody know what version of Zookeeper I should use?

I'm extremely new to this so forgive me for any incorrect terminology, etc, I use.

Thanks for all your help!


Expert Contributor
@katelyn thomas

If you use the 'asparagus' chart below (even if you are not using HDP), you can select the combination of components that have been tested with each other. Not just Storm, ZK, but also Kafka, HDFS, etc., depending on what your source/targets are:

The Hortonworks Sandbox contains all of the HDP components installed, configured, and ready to use.

The Partner Demo kit also has a Storm use case pre-built: