Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

New Contributor

When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

I have started hbase thrift server in different host to hue server, added hbase_cluster=(hbase1:hbase thrift server:9090), and restart hue service with CM, but the error still show up。huehost:8888/dump_config as fellow:

hbase_clusters

(Cluster|localhost:9090)

Comma-separated list of HBase Thrift servers for clusters in the format of '(name|host:port)'.

默认值: (Cluster|localhost:9090)

 

 

 obvious it is not correct, but how to configure correctly?

How to fix it? anyone help , thanks:heart:

 

 

4 REPLIES 4

Re: When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

Cloudera Employee

Hi bihadooper, do you also happen to have Kerberos security enabled on this cluster?

 

-roland

Re: When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

If you are using CM you need to add the properties into the Hue safety valve:

 

 http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Free/4.5.4/Cloudera-Manager-Free-E...

 

e.g.

 

[hbase]

hbase_clusters=(hue-ent|hu.com:9090)

Re: When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

New Contributor

Hi, rteague, i did not have Kerberos security enabled.

 

Re: When I use Hbase browser in hue 2.5.0 , show error: Could not connect to localhost:9090。

You need to replace localhost by the address of the Thrift server.

Don't have an account?
Coming from Hortonworks? Activate your account here