Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor
I've installed HDP2.5 using ambari2.4.1,when I add ambari_infra service or ranger service,the ambari option failed and exception shows like(It seems the reason is loss of some rpm pakages,but I can find it  ):

2016-11-03 08:57:59,849 - Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 376, in install_packages
    retry_count=agent_stack_retry_count
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 58, in action_upgrade
    self.upgrade_package(package_name, self.resource.use_repos, self.resource.skip_repos)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 54, in upgrade_package
    return self.install_package(name, use_repos, skip_repos, is_upgrade)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 49, in install_package
    self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput())
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 83, in checked_call_with_retries
    return self._call_with_retries(cmd, is_checked=True, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 91, in _call_with_retries
    code, out = func(cmd, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 71, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 93, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 141, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 294, in _call
    raise Fail(err_msg)
Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 469, in <module>
    InstallPackages().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 179, in actionexecute
    raise Fail("Failed to distribute repositories/install packages")
resource_management.core.exceptions.Fail: Failed to distribute repositories/install packages
6 REPLIES 6

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor

@rila kwan

can you please confirm ambari.repo file is available under /etc/yum.repos.d/ path on all ambari-agent host or on the host where you are trying to install ambari-infra/ranger service

If available then can you run

yum clean all

and try installing the services.

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor

thanks for your answer, actually the ambari.repo file has no problem, the problem is that my ambari local repository only has the following rpm packages:

ambari-agent-2.4.1.0-0.x86_64.rpm ambari-metrics-collector-2.4.1.0-0.x86_64.rpm ambari-metrics-grafana-2.4.1.0-0.x86_64.rpm ambari-metrics-hadoop-sink-2.4.1.0-0.x86_64.rpm ambari-metrics-monitor-2.4.1.0-0.x86_64.rpm ambari-python-shell-2.4.1.0-0.x86_64.rpm ambari-server-2.4.1.0-0.x86_64.rpm python-client-2.4.1.0-0.x86_64.rpm

and my develop commend is :

mvn -B install package rpm:rpm -DnewVersion=2.4.1.0.0 -DskipTests -Dpython.ver="python >= 2.6"

Does it have any problems?thank you again.

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor
@rila kwan

Looks like you have locally compiled and installed Ambari, in that case you will need to manually install the ambari-infra-solr-client rpm package which will be available under ambari-logsearch -> ambari-logsearch-solr-client -> target -> rpm -> ambari-logsearch-solr-client -> RPMS -> noarch -> ambari-logsearch-solr-client-****.noarch.rpm

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor

@vsuvagia

I am having the same issue as the OP. Could you please elaborate a little more on how to install ambari-infra-solr-client?

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor

@rila kwan Have you solved this issue?

Highlighted

Re: When using HDP2.5.0.0 I installed ambari_infra or ranger ,exception occured with " Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install ambari-infra-solr-client' returned 1. Error: Nothing to do"

New Contributor

I was able to get these files from the hortonworks sandbox. I ransudo yumdownloader ambari-infra-solr and sudo yumdownloader ambari-infra-solr-client to obtain the appropriate files.

Don't have an account?
Coming from Hortonworks? Activate your account here