Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Which Metron project do I use from github?

Highlighted

Which Metron project do I use from github?

Explorer
@asubramanian

Hey Anand,

I have downloaded incubator-metron, apache-metron-0.4.1-rc4 & apache-metron-0.4.2-rc2 but none of them are able to build properly, it is giving me mvn failed to build error.

I have correctly installed maven 3.3.9 and also put correct path in bash_profile.

Can you help me out with proper installation for the same.

Regards,

Gaurav

6 REPLIES 6

Re: Which Metron project do I use from github?

Contributor

Hi @Gaurav Bapat,

Did you followed the instructions below "Building Metron" chapter:

https://github.com/apache/metron

Current release:

http://metron.apache.org/documentation/#releases

You can also use HCP following the instructions below:

https://docs.hortonworks.com/HDPDocuments/HCP1/HCP-1.4.1/bk_installation/content/installing_ambari_m...

Gonçalo

Highlighted

Re: Which Metron project do I use from github?

Explorer

67484-screenshot-2.png

67485-screenshot-1.png

I run mvn clean compile -DskipTests -PbuildRmps in metron-deployment folder

Highlighted

Re: Which Metron project do I use from github?

Contributor

It seems that you are having an error accessing the repos. Do you have internet on that machine? If not, then you need to download all the dependencies of the package so that Maven is able to build the package.

Highlighted

Re: Which Metron project do I use from github?

Super Collaborator
@Gaurav Bapat

I am assuming you have provided the right switch for the command (is that a typo in your comment when you said '-PbuildRmps'?)

Can you check if Docker service is up and running ?

Please paste the output of metron-deployment/scripts/platform-info.sh as well.

Highlighted

Re: Which Metron project do I use from github?

Explorer

Metron 0.4.1
fatal: Not a git repository (or any parent up to mount point /home)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
--
ansible 2.0.0.2
config file =
configured module search path = Default w/o overrides
--
Vagrant 1.9.6
--
Python 2.7.5
--
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T22:11:47+05:30)
Maven home: /opt/maven/3.3.9
Java version: 1.8.0_161, vendor: Oracle Corporation
Java home: /opt/jdk1.8.0_161/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.10.0-327.el7.x86_64", arch: "amd64", family: "unix"
--
./platform-info.sh: line 64: docker: command not found
--
node
v6.12.3
--
npm
3.10.10
--
Linux localhost.localdomain 3.10.0-327.el7.x86_64 #1 SMP Thu Nov 19 22:10:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
--
Total System Memory = 48112 MB
Processor Model: Intel(R) Xeon(R) CPU E5-2420 v2 @ 2.20GHz
Processor Speed: 2163.820 MHz
Processor Speed: 2054.593 MHz
Processor Speed: 2200.000 MHz
Processor Speed: 2199.312 MHz
Processor Speed: 2045.656 MHz
Processor Speed: 2198.882 MHz
Processor Speed: 2199.312 MHz
Processor Speed: 2200.343 MHz
Processor Speed: 2197.593 MHz
Processor Speed: 2177.656 MHz
Processor Speed: 2199.914 MHz
Total Physical Processors: 12
Total cores: 72
Disk information:
/dev/mapper/centos-root 4.0T 13G 3.9T 1% /
/dev/sda2 238G 199M 238G 1% /boot
/dev/sda1 100G 11M 100G 1% /boot/efi
/dev/mapper/centos-home 3.0T 9.7G 3.0T 1% /home
/dev/mapper/centos-var 1.8T 1.2G 1.8T 1% /var
This CPU appears to support virtualization

Highlighted

Re: Which Metron project do I use from github?

Super Collaborator

Here's the issue... you need to install docker

./platform-info.sh: line 64: docker: command not found
Don't have an account?
Coming from Hortonworks? Activate your account here