Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Which version of R is compatible with Spark 2.3.0 HDP 2.6.5

Highlighted

Which version of R is compatible with Spark 2.3.0 HDP 2.6.5

New Contributor

Hello ,

Which version of R is compatible with Spark 2.3.0 & Spark 1.6.3 in HDP 2.6.5.0-292 .

We plan to use SparkR for Spark and Spark2 on Cli as well as RStudio .

I earlier had R 2.3.1 and was getting the below warning

Version mismatch between Spark JVM and SparkR package. JVM version was 2.3.0.2.6.5.0-292 , while R package version was 2.3.1

1 REPLY 1

Re: Which version of R is compatible with Spark 2.3.0 HDP 2.6.5

Hello @tauqeer khan!
You can use any R version >= 3.0
https://spark.apache.org/docs/2.3.0/api/R/index.html

Hope this helps.

Don't have an account?
Coming from Hortonworks? Activate your account here