Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

Highlighted

While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

New Contributor
==========================
Creating target directory...
==========================

Command start time 2016-03-22 05:55:43

Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
SSH command execution finished
host=192.168.91.128, exitcode=255
Command end time 2016-03-22 05:55:44

ERROR: Bootstrap of host 192.168.91.128 fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).

STDOUT: 
Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
7 REPLIES 7
Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

Contributor

Check if you have provided the correct ssh key. The key should be the private ssh key and not the public ssh key. On the command line try to ssh manually with those credentials and see if you can SSH.

Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

@ vivek durai

Please check the private ssh key and the user as well with whom u did password less SSH setup on this master to slave nodes.

Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

New Contributor

Thanks @jluniya.

I have provided the correct ssh key. Also, I am able to ssh manually from the source to destination host.

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

Expert Contributor

Try ssh to 192.168.91.128 and confirm that password is not required.

Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

@ vivek durai Make sure you have passwordless ssh configured properly from Ambari-server to "192.168.91.128"

Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

Expert Contributor

If you really have setup password less SSH correctly and are using the private key please try and upgrade your OpenSSL version. The version of openssl should be above 1.0.1e-15

There is a known bug, which is fixed in CentOS 6.6 and openssl 1.0.1e-16 : https://bugzilla.redhat.com/show_bug.cgi?id=1025598

It's a shoot in the wild but maybe it helps.

If you need further help you have to provide more details to your setting then just posting the error message. Provide at least your OS, Ambari, and HDP version.

Highlighted

Re: While registering a node with ambariserver, I am getting the following error. Can someone please help me to fix the issue?

Expert Contributor
Don't have an account?
Coming from Hortonworks? Activate your account here