Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Why my Hawq stand by master Isn't runing ? And my cluster seems fine but it's doesn't work either ?

Highlighted

Why my Hawq stand by master Isn't runing ? And my cluster seems fine but it's doesn't work either ?

Contributor

Hello,

I have some problem to run my hawq cluster and i would like some help or advice

right now I have this :

11960-capture3.png

11971-capture4.png

I have kerberos on hadoop plateform ( just for information ) , when i try to launch my stanby master i get this :

11972-capture6.pngand when i tried to use my hawq cluster as gpadmin i get this :

11973-capture7.png

I thank you in adnvance for your time

Toky

3 REPLIES 3

Re: Why my Hawq stand by master Isn't runing ? And my cluster seems fine but it's doesn't work either ?

Contributor

Did this happen from the beginning right after install? You'll have to check what the logs say on the Standby master:

http://hdb.docs.pivotal.io/211/hawq/admin/logfiles.html

And is port 5432 in use already on Standby Master node by another postgres instance? What else is located on that node? Looks like standby master didn't get initialized.

Re: Why my Hawq stand by master Isn't runing ? And my cluster seems fine but it's doesn't work either ?

Contributor

Hi @Vineet,

Yes this happened and keep happening after the install.

I've found this :

11997-capture11.png

11997-capture11.png

on this file /home/gpadmin/hawqAdminLogs/hawq_init_20170125.log.

Port 5432 doesn't seems used

11998-capture9.png

And i have this installed on my node

11999-capture10.png

When i tried to initiate the standby master i have "hawq command not found"

Toky

Re: Why my Hawq stand by master Isn't runing ? And my cluster seems fine but it's doesn't work either ?

New Contributor

Can you try to manually run the following command on the HAWQ Standby Master node?

Please run these commands as the user 'gpadmin'

source /usr/local/hawq/greenplum_path.sh

hawq init standby -a

Don't have an account?
Coming from Hortonworks? Activate your account here