Support Questions
Find answers, ask questions, and share your expertise

Zeppelin UI does not run

Zeppelin UI does not run

ambari.pngzeppelinui.pnglog-files-of-zeppelin.png

Hi all,

For my task, I would like to use Zeppelin from my Hortonworks sandbox. I installed Zeppelin service via Ambari successfully but when I try to launch the UI, it does not respond. What could be the issue?
I checked the logs, changed the ports in env files of zeppelin, telnet the port 9996 with the hostname mentioned, but still no success. I have attached the snapshots.

6 REPLIES 6

Re: Zeppelin UI does not run

Mentor

@Jasim Waheed Ansari

Whats the entry in your /etc/hosts?

what is the output of the below cmd on your sandbox

# ifconfig 

Whatever IP you get from the above add this entry to your /etc/hosts as a new line eg

192.169.20.16   sandbox.kylo.io       sandbox

Then you will be able t access you Zeppelin UI through

http://sandbox.kylo.io:9996  or
http://sandbox:9996

Tell me if that helps

Re: Zeppelin UI does not run

Hi @Geoffrey , i used the sandbox's ifconfig ip in /etc/hosts as shown in attachment. The result is still the same, unable to access it.


etchosts.pngifconfig.png

Re: Zeppelin UI does not run

Mentor

@Jasim Waheed Ansari

How is the networking set for your sandbox ?

Can you give me a screenshot?

Re: Zeppelin UI does not run

Hi ,

Attached are the network setup of my sandbox.

network-1.png

network-2.png


Thank you.

Re: Zeppelin UI does not run

Mentor

Network-1.png already warns there is a problem never ignore such errors !
You can choose

- Bridged Adapter
- Host-only Adapter

depending on your config or do port forwarding as Jay says!

Re: Zeppelin UI does not run

Super Mentor

@Jasim Waheed Ansari

Looks like in your port forwarding the Zeppelin Port 9995 is not added so it will not be accessible from your local machine.

Can you please add the port forwarding as following in your NAT network setting

25390-zeppelin-port-forwarding.png

.