Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Zeppelin broken pipe issue

Highlighted

Zeppelin broken pipe issue

New Contributor

We have multiple users using zeppelin UI to submit Hive and spark queries.
Initially we had zeppelin 0.7.0 installed and then we upgraded the HDP pack from 2.6.0 to 2.6.5. With this pack zeppelin 0.7.3 was installed. With the new version of zeppelin we started facing issues such as broken pipe and zeppelin UI slowness.

We used to get broken pipe issues earlier with zeppelin 0.7.0 but it used to get resolved by simply restarting the hive interpreter. But with zeppelin 0.7.3 restarting the hive interpreter would result in zeppelin service crash. In order to resolve we had to restart the zeppelin service.

Upon raising the concern with the Hortonworks community, we were suggested to upgrade the zeppelin service from 0.7.3 to 0.8.0 version. With the current zeppelin version i.e 0.8.0 the frequency of broken pipe error has gone up. We are able to resolve this error by restarting the hive interpreter but the end users are concerned with the frequency at which this issue is occurring.

Note: We have user impersonation (per user and isolated mode) enabled for Hive and Spark interpreters. So at the back end for every user it creates a new interpreter connection. We have observed the if that user doesn't submit query for a long time, it breaks the connection between hiveserver2 (installed on another machine) and interpreter. But at the hiveserver2 end the connection doesn't close properly. We think this leads to broken pipe issue.


Can someone help with any configuration changes which would help us resolve this issue?