Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Zookeeper Smoke test failing when on the 9th step of Install, start and test ambari setup

I get the following screen while installing because of the error

2264-1583a432aa7fcefcb18894f98d4a593c26ff45e3efdcd72b80.png

The installation has not completed because of the zookeeper failing to pass the smoke test thus halting the processes further and giving 100% complete and with warning error on the installation page I have attached the zookeeper.txt file which shows the error.

1 ACCEPTED SOLUTION

Mentor

@Kunal Gaikwad

Failed connect to node3.dtitsupport247.net:50075; No route to host !!
Your hostnode3 is not reachable .. most probable issue wit the network setting routing tables.
- Verify the entries in your /etc/hosts
- Check the default gateway
- check the firewall is off
Just check that you didn't miss a step in the attached doc
Then retry !!

View solution in original post

17 REPLIES 17

@Kunal Gaikwad

I have experienced this several times.

Hit next

Move forward

Then you can run zk service check later once you are on dashboard

@Artem Ervits

It's new install...no Kerberos in the pic

@Neeraj Sabharwal This is a fresh installation of a cluster, there is no kerberos been configured here in this cluster.

Even I refreshed this page but the same this happens, I dont want to reconfigure and reinstall? can we do something here

@Kunal Gaikwad

I know there is no kerberos. Don't refresh the page

Hit next and accept...you will come out install wizard then you can run zk check

I did next and completed the installations but many services are not running including. do you have a link which I can refer to? I am not sure what has caused the installation failure so very difficult to decide what step has to be done. I am installing it for the first time

@Kunal Gaikwad

That's expected. Now, start HDFS, MapReduce, Yarn, Zookeeper, Hive and other services manually

FYI: Your install did not fail. It's service check only and I have experienced it many times.

Install finishes at 33% then service start etc. starts.

@Neeraj Sabharwal

Yes, I have been able to successfully turn up the services of HDFS but for MapReduce the history server gives an error. Nt sure why am i getting this error:

resource_management.core.exceptions.Fail: Execution of 'curl -sS -L -w '%{http_code}' -X PUT -T /usr/hdp/2.3.4.0-3485/hadoop/mapreduce.tar.gz 'http://node1.dtitsupport247.net:50070/webhdfs/v1/hdp/apps/2.3.4.0-3485/mapreduce/mapreduce.tar.gz?op=CREATE&user.name=hdfs&overwrite=True&permission=444' 1>/tmp/tmpZ5Y51c 2>/tmp/tmpnaJYGu' returned 7. curl: (7) Failed connect to node3.dtitsupport247.net:50075; No route to host

@Kunal Gaikwad See this

Failed connect to node3.dtitsupport247.net:50075; No route to host

Make sure datanodes are up and connection between servers is working.

@Neeraj Sabharwal

Yes, the datanode and the namenode is up, but I noticed that from the hdfs service page from the quick link I am unable to see anything on the NameNode UI link, it says webpage not available, guess that is the reason why it is not able to establish a connection if I am not wrong? what can I do here?

my core-site.xml has

<value>hdfs://node1.dtitsupport247.net:8020</value>

even changing the port no. here from 8020 to 50070 does not help, none of the quicklinks are opening, says page does not exists

I tried running:

 ps -ef | grep hadoop | grep -P  'namenode|datanode|tasktracker|jobtracker'

I have attached the output for it: outpt1.txt

@Kunal Gaikwad Is node1.dtitsupport247.net FQDN? Are you able to reach that url at all from you laptop?

@Neeraj Sabharwal

Yes i was able to read that from my laptop only the ones with node2 and node 3 were not accessible

@Kunal Gaikwad That's the issue..

Whats the final resolution of the real problem?

I did a lot of steps to be true, not sure which resolved it actually!

I'll list all that I did:

I installed knox manually, changed the firewall settings, checked if all port were accessible from all the nodes. From what I think changing the port number for fs.default.name from 50070 to 8020 resolved it.

Mentor

@Kunal Gaikwad

Failed connect to node3.dtitsupport247.net:50075; No route to host !!
Your hostnode3 is not reachable .. most probable issue wit the network setting routing tables.
- Verify the entries in your /etc/hosts
- Check the default gateway
- check the firewall is off
Just check that you didn't miss a step in the attached doc
Then retry !!

@Geoffrey Shelton Okot

Yes, each of those steps have been followed the issues is still the same.

Mentor

@Kunal Gaikwad

I know it's a tough thing to ask but the error is a connection problem so go again through the check list. Additionally restart the NTP servers on the 3 hosts. Check for whitespace in node3.dtitsupport247.net config files

- /etc/hosts

- /etc/sysconfig/network

- /etc/sysconfig/network-scripts/eth*

- Disable TPH

Keep me posted

@Geoffrey Shelton Okot

I have checked the configs I have seen it all fine except i was unable to navigate to http://node1.dtitsupport247.net:50070/webhdfs/ even locally so I checking for the Knox services, I could see the Knox gateway been installed and all the user and directories in place. But i did a yum install knox, changed the port from 50070 back to 8020 and check few config files also referring some related issues in the forum and restarted the cluster and bought up all the components up! Its working now! Finally!

Thank you all! @Geoffrey Shelton Okot @Artem Ervits @Neeraj Sabharwal for the expert solutions here!