Support Questions

Find answers, ask questions, and share your expertise

add node to the ambari cluster the next button not active in Assign Slaves and Clients window

I Add Node to cluster - Assign Slaves and Clients window doesn't go forward. (I want to add new node to the ambari cluster )

I have registered a host successfully. Put tick marks on the slaves and client boxes, however, unable to go forward after that. ( the <next> button not active )

How to enable the next button to continue the add node process

Michael-Bronson
1 ACCEPTED SOLUTION

Super Mentor

@uri ben-ari

1. In the new node where you want to install the Slaves like DataNode & NodeManager .. Do you see any strange error/warning in the ambari-agent logs?

2. Have you tried refreshing the page (where the "Next" button is disabled).

3. Have you tried using a WebBrowser in "Incognito Mode" (Just to isolate the possibility of browser cache).

4. Do you see any error/warning in the ambari server log?

5. It might be a UI issue, so in order to find that out can you please check the "Console" log .. if any error mentioned there. You can enable Debugger tool as following:

Google Chrome --> "More Tools" --> "Developers Tools" 

.

View solution in original post

2 REPLIES 2

Super Mentor

@uri ben-ari

1. In the new node where you want to install the Slaves like DataNode & NodeManager .. Do you see any strange error/warning in the ambari-agent logs?

2. Have you tried refreshing the page (where the "Next" button is disabled).

3. Have you tried using a WebBrowser in "Incognito Mode" (Just to isolate the possibility of browser cache).

4. Do you see any error/warning in the ambari server log?

5. It might be a UI issue, so in order to find that out can you please check the "Console" log .. if any error mentioned there. You can enable Debugger tool as following:

Google Chrome --> "More Tools" --> "Developers Tools" 

.

I think i know the problem , I will explain , we reinstall again all 3 masters machines without to delete the workers machine from the cluster , now we want to add them back to the cluster , but we get warning about the current configuration on the workers ,

so my question is - how to re-delete the workers machine from the cluster in spite the masters machine are new machines?

what we can do in order to add the workers machine again to the ambari cluster?

* we have more then 20 workers machine that we need to add to the cluster , and they not deleted from the cluster before we reinstall the masters machine )

Michael-Bronson
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.