Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

Recently we upgraded BDA to 4.2/cdh 5.4.0, after upgrade I could see configuration parameter needs to  be fixed, below the screen shot  and error log information

 hue conf parameter issue.PNG

Log info:

opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/lib/hue/build/env/lib/python2.6/site-packages/requests-2.6.0-py2.6.egg/requests/packages/urllib3/connection.py:251: SecurityWarning: Certificate has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)

 

as per log info https://github.com/shazow/urllib3/issues/497, removed support for common name (cn) in certificates and deprecate support for use of common names when a certificate doesn't provide a subjectAltName

 

any idea how  to resolve.

 

Thanks

 

9 REPLIES 9

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

Any idea?

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

We are having a look at the warning.

What is the App configuration error in the bottom of the Screenshot?

Romain

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

bottom

Impala EditorNo available Impalad to send queries to.

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

Any update on this.

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Bit obvious but in case, in CM, are all the Impalad green?

Are you using ldap auth for Impala?


Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

Imapala is Gree, Yes we are using Kerbes/LDAP. 

 

Do you need any more information, please let  me know.

 

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Cloudera Employee

Hello,

 

The warning is coming from one of our dependencies, the requests library. It's just warning that one of the services we're connecting to is using a SSL certificate with some depredcated features. Eventually a future version of requests will reject certificates with these features, so someday whomever is generating those certificates should change how they are created, but it shouldn't be an issue now.

 

On the impala issue, just to confirm, is the Hue Impala app working for you? If not, does the `impala-shell` commandline tool work?

Re: after upgrade oracle BDA 4.2/CDH 5.4.0... conf parameter issue - need help on this

Explorer

Thanks for the update. 

 

Yes it is SSL and LDAP configuration issue. 

 

Impala shell working with out SSL.

Hue/Impala is not working(not  able to see DB's and tables). 

 

Thanks

Ravi.