Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

agent 5.0 installation fails looking for cyrus-sasl-gssapi

agent 5.0 installation fails looking for cyrus-sasl-gssapi

New Contributor

There is a dependency check failing during installation of the agent on a rocks/centos 6.5 cluster.  As far as I can tell the cyrus-sasl-gssapi routine is actually located in the cyrus-sasl-lib, not as a separate entity.  Here is the detail log:

 

BEGIN sudo yum info cloudera-manager-agent
Available Packages
Name : cloudera-manager-agent
Arch : x86_64
Version : 5.0.0
Release : 1.cm500.p0.215.el6
Size : 3.7 M
Repo : cloudera-manager
Summary : The Cloudera Manager Agent
URL : http://www.cloudera.com
License : Proprietary
Description : The Cloudera Manager Agent.
:
: The Agent is deployed to machines running services managed by
: Cloudera Manager.

END (0)
Version : 5.0.0
Release : 1.cm500.p0.215.el6
BEGIN sudo yum -y install cloudera-manager-agent
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package cloudera-manager-agent.x86_64 0:5.0.0-1.cm500.p0.215.el6 will be installed
--> Processing Dependency: fuse for package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64
--> Processing Dependency: fuse-libs for package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64
--> Processing Dependency: libxslt for package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64
--> Processing Dependency: cyrus-sasl-gssapi for package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64
--> Running transaction check
---> Package cloudera-manager-agent.x86_64 0:5.0.0-1.cm500.p0.215.el6 will be installed
--> Processing Dependency: cyrus-sasl-gssapi for package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64
---> Package fuse.x86_64 0:2.8.3-4.el6 will be installed
---> Package fuse-libs.x86_64 0:2.8.3-4.el6 will be installed
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
--> Finished Dependency Resolution
Error: Package: cloudera-manager-agent-5.0.0-1.cm500.p0.215.el6.x86_64 (cloudera-manager)
Requires: cyrus-sasl-gssapi
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

Tom

2 REPLIES 2

Re: agent 5.0 installation fails looking for cyrus-sasl-gssapi

Super Guru

I recommend checking to see if it is, indeed, installed with:

 

yum info cyrus-sasl-gssapi

 

On mine, see:

 

Loaded plugins: fastestmirror, security

Loading mirror speeds from cached hostfile

 * base: mirror.symnds.com

 * extras: mirror.itc.virginia.edu

 * updates: centos.aol.com

Installed Packages

Name        : cyrus-sasl-gssapi

Arch        : x86_64

Version     : 2.1.23

Release     : 13.el6_3.1

Size        : 31 k

Repo        : installed

From repo   : base

Summary     : GSSAPI authentication support for Cyrus SASL

URL         : http://asg.web.cmu.edu/sasl/sasl-library.html

License     : BSD

Description : The cyrus-sasl-gssapi package contains the Cyrus SASL plugins which

            : support GSSAPI authentication. GSSAPI is commonly used for Kerberos

            : authentication.

 

Perhaps trying to yum install manually will show more about what the problem is...

Re: agent 5.0 installation fails looking for cyrus-sasl-gssapi

New Contributor

With your help I found it in the base repo.  The repos are disabled by default in rocks so it pulls from the server.  I searched the updates repo, but not the base repo.

 

Tom