Support Questions
Find answers, ask questions, and share your expertise

ambari HIVE check fails

Ambari 2.5.1 hadoop 2.5

running check from ambari it fails

resource_management.core.exceptions.ExecutionFailed: Execution of '/var/lib/ambari-agent/tmp/templetonSmoke.sh server.domain.com ambari-qa 50111 idtest.ambari-qa.1499352141.17.pig /etc/security/keytabs/smokeuser.headless.keytab true /usr/bin/kinit ambari-qa-Cluster@DOMAIN.COM /var/lib/ambari-agent/tmp' returned 1. Templeton Smoke Test (ddl cmd): Failed. : {"error":"java.lang.reflect.UndeclaredThrowableException"}http_code <500>

1 ACCEPTED SOLUTION

@Indrek Mäestu

ROOT CAUSE

I hope hadoop.proxyuser.HTTP.hosts was not set to the host where webhcat was running.

RESOLUTION

1. Identify and note the node where WebHCat Server runs

2. Using Ambari HDFS-Configs, check if hadoop.proxyuser.HTTP.hosts is defined in core-site section or change as below

hadoop.proxyuser.HTTP.hosts=*
hadoop.proxyuser.HTTP.groups=*

3. If exists, update the parameter to include the WebHCat node name

4. If not, add the parameter and include WebHCat node name to the same

5. Restart all the services that needs restart including Hive

6. Run Hive service check again

Hope this helps you.

View solution in original post

2 REPLIES 2

@Indrek Mäestu

ROOT CAUSE

I hope hadoop.proxyuser.HTTP.hosts was not set to the host where webhcat was running.

RESOLUTION

1. Identify and note the node where WebHCat Server runs

2. Using Ambari HDFS-Configs, check if hadoop.proxyuser.HTTP.hosts is defined in core-site section or change as below

hadoop.proxyuser.HTTP.hosts=*
hadoop.proxyuser.HTTP.groups=*

3. If exists, update the parameter to include the WebHCat node name

4. If not, add the parameter and include WebHCat node name to the same

5. Restart all the services that needs restart including Hive

6. Run Hive service check again

Hope this helps you.

Yeah. added into "Custom webhcat-site" under hive conf in ambari

webhcat.proxyuser.HTTP.groups=*

webhcat.proxyuser.HTTP.hosts=*

; ;