Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

ambari-agent start failed

Explorer

The agent does not start. Looks like OpenSSL is missing - it isn't.

Any ideas?

The rpm is:

ambari-agent-2.2.1.1-70.x86_64

>> ambari-agent start Verifying Python version compatibility... Using python /usr/bin/python Checking for previously running Ambari Agent... /var/run/ambari-agent/ambari-agent.pid found with no process. Removing 7128... Starting ambari-agent Verifying ambari-agent process status... ERROR: ambari-agent start failed. For more details, see /var/log/ambari-agent/ambari-agent.out: ==================== Can't open library libX11.so.6: libssl.so: cannot open shared object file: No such file or directory ==================== Agent out at: /var/log/ambari-agent/ambari-agent.out Agent log at: /var/log/ambari-agent/ambari-agent.log

Red Hat Enterprise Linux Server release 6.7 (Santiago) java version "1.8.0_77" Java(TM) SE Runtime Environment (build 1.8.0_77-b03) Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Package openssl-1.0.1e-42.el6_7.2.x86_64 already installed and latest version Package libXt-1.1.4-6.1.el6.x86_64 already installed and latest version Package libX11-1.6.0-6.el6.x86_64 already installed and latest version

1 ACCEPTED SOLUTION

Explorer

Fixed:

Missing packages on RHEL 6.7 that I am guessing were:

  1. openssl-devel-1.0.1e-42.el6_7.2.x86_64
  2. krb5-devel-1.10.3-42.el6.x86_64

Pity the python rpms don't seem to depend on them ...

View solution in original post

5 REPLIES 5

What version of Python is already installed? Python v2.6 is the minimum requirement. Python v2.7.9 or later is not supported due to changes in how Python performs certificate validation. See Ambari software requirements.

Explorer

Yes it is:

python -V Python 2.6.6

Any other ideas?

Expert Contributor

This could be because, lib referred might be of 32 bit. Can you check which one is being used.

Explorer

Fixed:

Missing packages on RHEL 6.7 that I am guessing were:

  1. openssl-devel-1.0.1e-42.el6_7.2.x86_64
  2. krb5-devel-1.10.3-42.el6.x86_64

Pity the python rpms don't seem to depend on them ...

What do you see in /var/log/ambari-agent/ambari-agent.out ?