Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

ambari metrics collector

avatar

ambari metrics collector got stopped on our machine. when we try to restart in ambari , it is failing. but when i check the processes on the machine, they are running.

Also i get ambari alerts as

Metrics Collector - Auto-Restart Status

Metrics Collector has been auto-started 2 times since 2016-07-29 00:12:30.

I do see the following error in the logs

: 6:50:24,047 ERROR [main] ZooKeeperWatcher:652 - hconnection-0x5a7005d-0x156315434410005, quorum=localhost:61181, baseZNode=/ams-hbase-unsecure Received unexpected KeeperException, re-throwing exception org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /ams-hbase-unsecure at org.apache.zookeeper.KeeperException.create(KeeperException.java:99) at org.apache.zookeeper.KeeperException.create(KeeperException.java:51) at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:1045) at org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper.exists(RecoverableZooKeeper.java:221) at org.apache.hadoop.hbase.zookeeper.ZKUtil.checkExists(ZKUtil.java:417) Opening socket connection to server localhost/127.0.0.1:61181. Will not attempt to authenticate using SASL (unknown error)

even i tried reinstalling metrics collector. but it is not working. any thoughts on how to fix this.

I have seen a few posts in the forum, already but none helps

1 ACCEPTED SOLUTION

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
15 REPLIES 15

avatar
Super Guru
@ARUN

Ambari metrics collector is built using HBase and Phoenix and HBase uses Zookeeper. Is your Zookeeper running fine? What about HMaster? Check the following pages and its child pages for details.

https://cwiki.apache.org/confluence/display/AMBARI/Metrics

avatar

@mqureshi, we are using the zookeeper provided by AMS and even the hbase is ams-hbase. metrics collector was abruptly stopped. would it have corrupted . do i need to check anything on that.

avatar
Super Guru

@ARUN

I cannot say if HBase is corrupted but you can try running "hbck" from your hbase install bin directory (the one for ams). If hbck does find any inconsistency, please follow the guidelines on this page to fix the issues.

http://hbase.apache.org/0.94/book/apbs03.html

If details on above page are not enough, please see Apendix C on this link.

avatar

Hbase in AMS is a standalone HBase and there is no need for hbck.

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Super Collaborator

Hi @Aravindan Vijayan

I've had the same issue, and your solution helped me. Thanks!

avatar
Super Collaborator

I've had the same issue and the solution helped @Aravindan Vijayan

avatar
Expert Contributor

Hi @Aravindan Vijayan

Thanks for the info. It actually resolved the issue for me but it seems that I have stuck with the same issue after couple of days. Is this a temporary solution (workaround)?

Thanks,

Tamil.

avatar
Expert Contributor

Hi @Aravindan Vijayan I have the same issue and deleted files but still AMS doesn't start