Support Questions
Find answers, ask questions, and share your expertise

ambari server not running

Re: ambari server not running

Explorer

@Jay SenSharma: Thanks for the quick response.

  • I am able to do telnet and ping from the client machine
  • The iptables and ip6tables were not turned off. I have already tried turning it off and it didn't work. now I have turned it off but still getting the issue.

Also I am attaching the agent logs after restarting the ambari-server with iptables turned off: agentlog01.txt

Re: ambari server not running

Super Guru

make sure you are using a new browser try chrome and firefox

Re: ambari server not running

Expert Contributor

if you are trying on HDP Sandbox, so I have mentioned try to reload on VMs...

As per the agent log ==>

Connection failed to http://xxx.yyy.ZZZ:8042/ws/v1/node/info
INFO 2017-05-09 10:09:21,700 logger.py:67 - Pid file /var/run/ambari-metrics-monitor/ambari-metrics-monitor.pid is empty or does not exist
ERROR 2017-05-09 10:09:21,700 script_alert.py:112 - [Alert][ams_metrics_monitor_process] Failed with result CRITICAL: ['Ambari Monitor is NOT running on xxx.yyy.ZZZ']
ERROR 2017-05-09 10:09:21,701 script_alert.py:112 - [Alert][yarn_nodemanager_health] Failed with result CRITICAL: ['Connection failed to http://xxx.yyy.ZZZ:8042/ws/v1/node/info (Traceback (most recent call last):\n  File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/alerts/alert_nodemanager_health.py", line 165, in execute\n    url_response = urllib2.urlopen(query, timeout=connection_timeout)\n  File "/usr/lib64/python2.6/urllib2.py", line 126, in urlopen\n    return _opener.open(url, data, timeout)\n  File "/usr/lib64/python2.6/urllib2.py", line 391, in open\n    response = self._open(req, data)\n  File "/usr/lib64/python2.6/urllib2.py", line 409, in _open\n    \'_open\', req)\n  File "/usr/lib64/python2.6

below settings are initial setup, hope you already set it.

provide below output..it will help to narrow down the issue

-cat /etc/hosts

-cat /etc/sysconfig/network

-cat /etc/selinux/config|grep "SELINUX"

-service iptables status

-ntpd service enabled and running ? /etc/rc.d/init.d/ntpd status

Re: ambari server not running

Expert Contributor

Also confirm on VMs settings to set bridged adapter and Allow All options ?