Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

ambari-server start gives error

ambari-server start gives error

New Contributor

Waiting for server start.........Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
ERROR: Exiting with exit code -1.
REASON: Ambari Server java process died with exitcode 255. Check /var/log/ambari-server/ambari-server.out for more information.

4 REPLIES 4
Highlighted

Re: ambari-server start gives error

Cloudera Employee

@TechAven - Can you run below command on the ambari-server host and share the output.

# ambari-server status.

Also can you check the error message in the ambari server logs(/var/log/ambari-server/ambari-server.log) during the time of the startup. If possible you can share the ambari server logs.

Re: ambari-server start gives error

New Contributor

@ngarg  this is the output of ambari-server status

Using python /usr/bin/python
Ambari-server status
Ambari Server not running. Stale PID File at: /var/run/ambari-server/ambari-server.pid

 

@ngargthis is the error in logs

Failed to run the Ambari Server
org.apache.ambari.server.AmbariException: Current database store version is not compatible with current server version, serverVersion=2.7.0.0, schemaVersion=2.4.3
at org.apache.ambari.server.checks.DatabaseConsistencyCheckHelper.checkDBVersionCompatible(DatabaseConsistencyCheckHelper.java:236)
at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:1096)
2019-09-16 12:58:49,481 INFO [main] AmbariServer:218 - Found org/apache/ambari/server/controller/AmbariServer.class class in file:/usr/lib/ambari-server/ambari-server-2.7.0.0.897.jar!/org/apache/ambari/server/controller/AmbariServer.class
2019-09-16 12:58:49,486 INFO [main] AmbariServer:1009 - STARTUP_MESSAGE: Starting AmbariServer.java executable

Re: ambari-server start gives error

Super Mentor

@TechAven 

If you can share the Full logs then we can help you better.

/var/log/ambari-server/ambari-server.out
/var/log/ambari-server/ambari-server.log

So far whatever you have shared in this thread is just the outcome of the failure.  If we want to find out the Cause of that failure then you should share the detailed Error/StackTrace ... that you will find in the above mentioned files. So better if you can attach those files here.

Re: ambari-server start gives error

Super Mentor

@TechAven 

Looks like you just updated your post with the error . .

We see the Error

 

Failed to run the Ambari Server
org.apache.ambari.server.AmbariException: Current database store version is not compatible with current server version, serverVersion=2.7.0.0, schemaVersion=2.4.3
at

 

 

This indicates that you are running Ambari Binary 2.7.0.0 version

But your Ambari DB schema is 2.4.3

 

You might not have performed the following command after upgrading your Ambari Binaries.

 

# ambari-server upgrade

 

 

Please check the following link . Step 14. "Upgrade Ambari Server database schema"   if you have missed to do that: https://docs.cloudera.com/HDPDocuments/Ambari-2.7.0.0/bk_ambari-upgrade/content/upgrade_ambari.html

.

Can you please confirm if you have installed the Ambari Server binaries recently?  What is the output of the following command.

 

 

# rpm -qa | grep ambari

 

 

 

Don't have an account?
Coming from Hortonworks? Activate your account here