Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

beeswax not authenticating to a secure zookeeper

beeswax not authenticating to a secure zookeeper

New Contributor

Hello

 

I'm successfully using Beeswax as a HIVE UI. I have createdexternal  tables from Hbase tables (STORED BY "org.apache.hadoop.hive.hbase.HBaseStorageHandler) and I'm able to query them, create more views, etc.

 

Recently, I have been asked to secure zookeeper with SASL and simple Digest Login. I managed to do that and I also managed  to get all the applications connecting to zookepper to query the HBase nodes  to authenticate correctly (even HBase itself now authenticates to the zookeeper using a simple Digest login configured in a JAAS file).

 

The problem is that I can't get  beeswax to do the same.

I added this property in the hive-env.sh file:

export  HIVE_OPTS="$HIVE_OPTS -Djava.security.auth.login.config=${HIVE_CONF_DIR}/conf/jaas.conf"

and in many other places within hive, but it doesn't appear to be seen by beeswax.

 

Is there any way to pass this JVM parameter -Djava.security.auth.login.config=${HIVE_CONF_DIR}/conf/jaas.conf
 to beeswax so that it can authenticate to Zookeeper with a common Digest authentication?

 

Thanks!

 

Antonio

 

1 REPLY 1

Re: beeswax not authenticating to a secure zookeeper

Master Guru
The Beeswax JVM properties can be tweaked from the /etc/hadoop/conf/hadoop-env.sh file. Have you tried placing it there?

If you're on CDH 4.4+, I'd also recommend reconfiguring Hue to use HS2 as the Beeswax App server point than the older Beeswax JVM.

If you use Cloudera Manager, this is auto-handled for you if you've simply enabled ZK security.