Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

cannot access Ambari dashboard

cannot access Ambari dashboard

New Contributor

I was following the "learning the ropes of hortonworks sandbox" tutorial but ran into multiple issues.

1. I imported the sandbox VM via VirtualBox, was able to get the 127.0.0.1/8000 url and get to the welcome page. but I can't load the dashboard (127.0.0.1/8080). I checked ambari status and it turned out ambari was inactive and I can't seem to start the ambari server (see attachement 1). ambari-inactive.png

2. I wanted to get the inet address using ifconfig, but somehow the VM window is really small and only shows a cut-off of the command output so I can't see the inet address (see attachment 2). I tried different view options but can't make the VM window bigger. I also can't seem to insert VBox guest addition (I read it has something to do with the guest window size). cut-off-output.png

Any help will be highly appreciated! I have spent way too much time on this - it seemed so easy on the tutorial!

8 REPLIES 8
Highlighted

Re: cannot access Ambari dashboard

New Contributor

Hello, can you try removing "service" from your commands.

Instead try:

	ambari-server start

Re: cannot access Ambari dashboard

New Contributor

Thank you iyoung. It'd complain "command not found" if I remove service

Re: cannot access Ambari dashboard

@Emma Liu

Inline are the comments -

1. For ambari server start please refer command passed by @jyoung. Use below command to start ambari server.

$ambari-server start

2. For ifconfig output use below command -

$ifconfig | less

[ NOTE: to quit from above command press 'q' ]

Let me know if that helps.

Re: cannot access Ambari dashboard

New Contributor

Thank you Sagar! The ifconfig|less definitely helped! I can now get my inet address (127.17.0.1) but appending :8080 still didn't load.

Re: cannot access Ambari dashboard

Mentor

@Emma Liu

Reimport a new image of the Sandbox and please follow the attached document after successful login get the IP address from the output of

# ifconfig 
# ambari-server start

After the Ambari has successfully started then point to the URL: http://IP_from_ifconfig:8080

Thats should help let me know

Re: cannot access Ambari dashboard

Expert Contributor

did you ssh using 22 or 2222?

Re: cannot access Ambari dashboard

New Contributor

Thank you. I was using docker but since tried 2222. Still getting error starting ambari ("database check failed") see attached snapshotambari-restart-error-database-check-failed.png

Re: cannot access Ambari dashboard

Expert Contributor

Hi @Emma Liu , did you get it running yet. If not, what steps did you try.

Once you login to 127.0.0.1 using port 2222 you should be asked to change your password from hadoop.

If you did that already, then enter this command and see what happens "ambari-admin-password-reset". I noticed in your first image that the os was centos7. As far as im aware, the sandbox is using centos6.8 and the docker is centos 7. Hope this helps.