Support Questions
Find answers, ask questions, and share your expertise

cloudera/quickstart on Ubuntu issues

cloudera/quickstart on Ubuntu issues

New Contributor



My first post here so let me know if I am posting this in the right place/if I should amend my post in any way.


I am trying to use the cloudera/quickstart docker container on Ubuntu 16.04, but regardless of how much I increase the container basesize to I get the same error: 

$ sudo docker pull cloudera/quickstart:latest

latest: Pulling from cloudera/quickstart
1d00652ce734: Downloading 4.444GB/4.444GB
write /var/lib/docker/tmp/GetImageBlob107502074: no space left on device

It does not appear to be an issue with my local machine running out of space. See below

$df -hk
Filesystem                  1K-blocks    Used Available Use% Mounted on
udev                          8195576       0   8195576   0% /dev
tmpfs                         1643180   58420   1584760   4% /run
/dev/mapper/systemvg-rootlv 156983148 1845280 148738276   2% /
/dev/mapper/systemvg-usrlv    5771200 1600284   3854708  30% /usr
tmpfs                         8215896       0   8215896   0% /dev/shm
tmpfs                            5120       0      5120   0% /run/lock
tmpfs                         8215896       0   8215896   0% /sys/fs/cgroup
/dev/sda1                      944120  180792    698152  21% /boot
/dev/mapper/systemvg-tmplv    2885584    4428   2714860   1% /tmp
/dev/mapper/systemvg-homelv    475754   37421    409252   9% /home
/dev/mapper/vg0-storage01   102049120 7729496  89112792   8% /storage01
/dev/mapper/systemvg-optlv    2885584 1096792   1622496  41% /opt
/dev/mapper/systemvg-varlv    4787516 1178488   3342788  27% /var

Here is the docker info

sudo docker info
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 0
Server Version: 18.06.0-ce
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: d64c661f1d51c48782c9cec8fda7604785f93587
runc version: 69663f0bd4b60df09991c08812a60108003fa340
init version: fec3683
Security Options:
  Profile: default
Kernel Version: 4.4.0-124-generic
Operating System: Ubuntu 16.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 8
Total Memory: 15.67GiB
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No swap limit support

I've tried pretty much everything google has given me to no avail. Anyone able to resolve this issue on Ubuntu? I can run it on Docker for Windows.