Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

comfirn hosts, ambari agent error,ambari agent installation issue

Solved Go to solution
Highlighted

comfirn hosts, ambari agent error,ambari agent installation issue

Explorer

62684-screenshot-2018-03-06-150706.png

I am trying to install hdp locally on ubuntu 16.04. I installed ambari, i launched the cluster installed wizzard,I Used Local Repository, here i left it empty i don't know what i have to put. then i entred my host 'hadoop' and i entred the 'ssh private key'. In the end of all I get an error during installation of 'Ambari' agent like its showing in the picture below.

,

I am trying to install hdp locally on ubuntu 16.04. I installed ambari, i launched the cluster installed wizzard,I Used Local Repository, here i left it empty i don't know what i have to put. then i entred my host 'hadoop' and i entred the 'ssh private key'. In the end of all I get an error during installation of 'Ambari' agent like its showing in the picture below.

62683-screenshot-2018-03-06-150706.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Contributor

@Aymen Rahal

Hi,

When registering host go with Manual Installation.

and edit /etc/ambari-agent/conf/ambari-agent.ini

change hostname=ambari server name

Then Retry Failed.

View solution in original post

7 REPLIES 7
Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

@Aymen Rahal

Can you click on 'Failed' and share the error shown?

Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Explorer
ssh: connect to host hadoop port 22: Connection refused
SSH command execution finished
host=hadoop, exitcode=255
Command end time 2018-03-06 19:50:20

ERROR: Bootstrap of host hadoop fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: ssh: connect to host hadoop port 22: Connection refused

STDOUT: 
ssh: connect to host hadoop port 22: Connection refused
Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Contributor

@Aymen Rahal

Hi,

When registering host go with Manual Installation.

and edit /etc/ambari-agent/conf/ambari-agent.ini

change hostname=ambari server name

Then Retry Failed.

View solution in original post

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Explorer

$ ambari-agent start

ambari-agent: command not found

Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Expert Contributor

@Aymen Rahal

if you are doing manual installation, you need to install ambari-agent first on each of your servers. use repos to install and edit the /etc/ambari-agent/conf/ambari-agent.ini to use the ambari server hostname and start ambari-agent.

when you are adding your hosts, use manual installation .. you dont need ssh key in this case.

Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

Explorer

awesome it works, thank you very much!

Highlighted

Re: comfirn hosts, ambari agent error,ambari agent installation issue

@Aymen Rahal

The issue is due to 'Connection refused on the default ssh port'. Verify the following:

1. Check the ssh port under file /etc/ssh/sshd_config, if not set try setting to 22.

2. Try running ssh to the host from terminal.

Don't have an account?
Coming from Hortonworks? Activate your account here