Support Questions
Find answers, ask questions, and share your expertise

creating table with .data and .item files taking much time and query not executing in HIVE.

Highlighted

creating table with .data and .item files taking much time and query not executing in HIVE.

New Contributor

I am uploading .data file and .item file but after initializing it with column names and clicking upload button, I have waited for 30-40 minutes but it still shows update In-Progress.

So finally I closed it but after reopening Ambari, I can see tables so I went ahead to fire a query in HIVE View but again I waited around 20 minutes and query is still not executed.

58418-upload.png

5 REPLIES 5
Highlighted

Re: creating table with .data and .item files taking much time and query not executing in HIVE.

New Contributor

@Harald Berghoff can you help?

Highlighted

Re: creating table with .data and .item files taking much time and query not executing in HIVE.

Contributor

if you are using files or dirs starting with . and _ they are considered to be hidden in hdfs .. check from hive console if you can see the path properly for the table that got created.

Highlighted

Re: creating table with .data and .item files taking much time and query not executing in HIVE.

New Contributor

I just removed sandbox from Virtual box and then again imported it.

Now it's working totally fine, I really have no idea what was going wrong.

Thanks a lot for your support.

Highlighted

Re: creating table with .data and .item files taking much time and query not executing in HIVE.

Super Collaborator

as you are running the sandbox, there might also be an issue with the resources assigned to the sandbox. Check if you have enough RAM assigned to the sandbox (if I am right, you should have at least 16 GB assigned).

To verify if there is an issue or not, you can login to the shell of the sandbox (using Putty or another ssh client) and check for the log of Hive (should be at /var/log/hive/ or /var/log/hive2/) If there is no error, it could be a resource issue.

Re: creating table with .data and .item files taking much time and query not executing in HIVE.

New Contributor

I just removed sandbox from Virtual box and then again imported it.

Now it's working totally fine, I really have no idea what was going wrong.

Thanks a lot for your support.