Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

dependency conflict error HDP 3.0 upgrade: freeipa

Solved Go to solution
Highlighted

dependency conflict error HDP 3.0 upgrade: freeipa

New Contributor

I am attempting to upgrade from HDP 2.6 to 3.0 and am encountering dependency conflicts related to freeipa on CentOS 7. Has anyone else encountered this? From a quick google search, the freeipa/ipa conflict is a known bug that can be ignored, but I am unsure of how to get Ambari to do so...or if that is a good idea:

stderr: 
2018-08-02 15:19:12,001 - Failed to verify package dependencies. Execution of '['/usr/bin/yum', '-d', '0', '-e', '0', 'check', 'dependencies']' returned 1. ipa-admintools-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-admintools: ipa-admintools-4.4.0-14.el7.centos.6.noarch
ipa-client-4.4.0-14.el7.centos.6.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.6.x86_64
ipa-client-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.6.noarch
ipa-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.6.noarch
2018-08-02 15:19:12,001 - Failure while verifying dependencies
2018-08-02 15:19:12,001 - *******************************************************************************
2018-08-02 15:19:12,001 - Manually verify and fix package dependencies and then re-run install_packages
2018-08-02 15:19:12,001 - *******************************************************************************
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 486, in 
    InstallPackages().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 353, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 149, in actionexecute
    raise Fail("Failed to distribute repositories/install packages")
resource_management.core.exceptions.Fail: Failed to distribute repositories/install packages
 stdout:
2018-08-02 15:18:48,195 - Will install packages for repository version 3.0.0.0
2018-08-02 15:18:48,195 - Repository for HDP/3.0.0.0/hdp-gpl is not managed by Ambari
2018-08-02 15:18:48,195 - Repository for HDP/3.0.0.0/hdp is not managed by Ambari
2018-08-02 15:18:48,195 - Repository for HDP/3.0.0.0/hdp-utils is not managed by Ambari
2018-08-02 15:18:48,196 - Yum non-completed transactions check passed
2018-08-02 15:18:48,196 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-08-02 15:18:48,223 - call returned (0, '2.6.2.0-205\n3.0.0.0-1634')
2018-08-02 15:18:48,224 - Installing package hdp-select ('/usr/bin/yum -y install hdp-select')
2018-08-02 15:18:51,152 - Looking for matching packages in the following repositories: hdp-gpl, hdp, hdp-utils
2018-08-02 15:18:59,136 - Installing package atlas-metadata_3_0_0_0_1634 ('/usr/bin/yum -y install atlas-metadata_3_0_0_0_1634')
2018-08-02 15:18:59,760 - Installing package ambari-infra-solr-client ('/usr/bin/yum -y install ambari-infra-solr-client')
2018-08-02 15:19:00,383 - Installing package kafka_3_0_0_0_1634 ('/usr/bin/yum -y install kafka_3_0_0_0_1634')
2018-08-02 15:19:00,914 - Installing package gcc ('/usr/bin/yum -y install gcc')
2018-08-02 15:19:01,444 - Installing package python-kerberos ('/usr/bin/yum -y install python-kerberos')
2018-08-02 15:19:02,066 - Installing package hadoop_3_0_0_0_1634 ('/usr/bin/yum -y install hadoop_3_0_0_0_1634')
2018-08-02 15:19:02,596 - Installing package hadoop_3_0_0_0_1634-client ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-client')
2018-08-02 15:19:03,220 - Installing package snappy ('/usr/bin/yum -y install snappy')
2018-08-02 15:19:03,749 - Installing package snappy-devel ('/usr/bin/yum -y install snappy-devel')
2018-08-02 15:19:04,369 - Installing package hadoop_3_0_0_0_1634-libhdfs ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-libhdfs')
2018-08-02 15:19:05,005 - Installing package hadoop_3_0_0_0_1634-mapreduce ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-mapreduce')
2018-08-02 15:19:05,649 - Installing package ambari-infra-solr-client ('/usr/bin/yum -y install ambari-infra-solr-client')
2018-08-02 15:19:06,293 - Installing package hbase_3_0_0_0_1634 ('/usr/bin/yum -y install hbase_3_0_0_0_1634')
2018-08-02 15:19:06,842 - Installing package phoenix_3_0_0_0_1634 ('/usr/bin/yum -y install phoenix_3_0_0_0_1634')
2018-08-02 15:19:07,387 - Installing package zookeeper_3_0_0_0_1634 ('/usr/bin/yum -y install zookeeper_3_0_0_0_1634')
2018-08-02 15:19:07,936 - Installing package zookeeper_3_0_0_0_1634-server ('/usr/bin/yum -y install zookeeper_3_0_0_0_1634-server')
2018-08-02 15:19:08,577 - Installing package hadoop_3_0_0_0_1634-yarn ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-yarn')
2018-08-02 15:19:09,221 - Installing package hadoop_3_0_0_0_1634-mapreduce ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-mapreduce')
2018-08-02 15:19:09,859 - Installing package hadoop_3_0_0_0_1634-hdfs ('/usr/bin/yum -y install hadoop_3_0_0_0_1634-hdfs')
2018-08-02 15:19:12,001 - Failed to verify package dependencies. Execution of '['/usr/bin/yum', '-d', '0', '-e', '0', 'check', 'dependencies']' returned 1. ipa-admintools-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-admintools: ipa-admintools-4.4.0-14.el7.centos.6.noarch
ipa-client-4.4.0-14.el7.centos.6.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.6.x86_64
ipa-client-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.6.noarch
ipa-common-4.4.0-14.el7.centos.6.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.6.noarch
2018-08-02 15:19:12,001 - Failure while verifying dependencies
2018-08-02 15:19:12,001 - *******************************************************************************
2018-08-02 15:19:12,001 - Manually verify and fix package dependencies and then re-run install_packages
2018-08-02 15:19:12,001 - *******************************************************************************
2018-08-02 15:19:12,002 - Installation of packages failed. Checking if installation was partially complete
2018-08-02 15:19:12,002 - Old versions: ['2.6.2.0-205', '3.0.0.0-1634']
2018-08-02 15:19:12,002 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-08-02 15:19:12,027 - call returned (0, '2.6.2.0-205\n3.0.0.0-1634')
2018-08-02 15:19:12,027 - New versions: ['2.6.2.0-205', '3.0.0.0-1634']
2018-08-02 15:19:12,028 - Deltas: set([])

Command failed after 1 tries

1 ACCEPTED SOLUTION

Accepted Solutions

Re: dependency conflict error HDP 3.0 upgrade: freeipa

New Contributor

As it were, being in a walled off environment that does not have the latest version of the CentOS repos, this was a significantly more head-scratching affair. As it turns out, the simple fix is to update yum, which fixes this bug. Unfortunately, that was not an option for me. Fortunately, there is a manual work-around that did work: Comment 17, which is to o the following:

sed -i "/for creq in pkg.conflicts:/a\ if creq[0].startswith('freeipa'): continue" /usr/lib/python2.7/site-packages/yum/rpmsack.py

So, in case someone else runs into this issue and is in the same type of restricted environment that I am in, this should fix things for you too...

1 REPLY 1

Re: dependency conflict error HDP 3.0 upgrade: freeipa

New Contributor

As it were, being in a walled off environment that does not have the latest version of the CentOS repos, this was a significantly more head-scratching affair. As it turns out, the simple fix is to update yum, which fixes this bug. Unfortunately, that was not an option for me. Fortunately, there is a manual work-around that did work: Comment 17, which is to o the following:

sed -i "/for creq in pkg.conflicts:/a\ if creq[0].startswith('freeipa'): continue" /usr/lib/python2.7/site-packages/yum/rpmsack.py

So, in case someone else runs into this issue and is in the same type of restricted environment that I am in, this should fix things for you too...