Support Questions
Find answers, ask questions, and share your expertise

docker exited with 139 when running cloudera/quickstart:latest

New Contributor

I followed the instructions on this link https://www.folio3.ai/blog/up-running-with-cloudera-quickstart-on-docker/ to run cloudera/quickstart from docker image on Windows 10 Version 2004 (Build: 19041.329) and Windows 10 Version: 20H2 (Build 19042.330) and in both platforms the image does not run exiting with 139 error code. I have no idea how to handle that. Please let me know if anyone can help on it.

After pull the image I got this message:

PS C:\Users\xxx> docker pull cloudera/quickstart:latest
latest: Pulling from cloudera/quickstart
Image docker.io/cloudera/quickstart:latest uses outdated schema1 manifest format. Please upgrade to a schema2 image for better future compatibility. More information at https://docs.docker.com/registry/spec/deprecated-schema-v1/
1d00652ce734: Pull complete
Digest: sha256:f91bee4cdfa2c92ea3652929a22f729d4d13fc838b00f120e630f91c941acb63
Status: Downloaded newer image for cloudera/quickstart:latest
docker.io/cloudera/quickstart:latest

14 REPLIES 14

Unfortunately I don’t have windows machine to test this out but this works flawlessly in Linux system. I am assuming kernel dump/system logs can give you guys some more insight. 
If someone have highly configured Win machine then we might isolate the memory issue if that’s the cause as suspected above. The image Ideally need 8-10GB RAM dedicated for this particular VM only. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

The WSL2 Engine is the culprit here. Revert to the non-WSL2 (Hyper-v) engine and it works.

Hi,
I am not getting an option to change the WSL settings in Docker desktop.

SuyogNagaokar_0-1636535077790.png

 

Please help !!

Community Manager

@SuyogNagaokar, as this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post.



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

Yes, I will start a new thread for this issue.

Just an update though...the issue was due to Windows 10 Home version. Upgrading to Pro should let me disable the WSL option.