Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

error install Hbase

avatar
Master Collaborator

Hi:

I am trying install Hbase and i am receiving this error:

[root@lnxbig06 current]# tail -200f /var/lib/ambari-agent/data/errors-6126.txt
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py", line 37, in <module>
    AfterInstallHook().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py", line 31, in hook
    setup_hdp_symlinks()
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/shared_initialization.py", line 44, in setup_hdp_symlinks
    hdp_select.select_all(version)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/hdp_select.py", line 122, in select_all
    Execute(command, only_if = only_if_command)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 158, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 121, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run
    tries=self.resource.tries, try_sleep=self.resource.try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
    raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of 'ambari-sudo.sh /usr/bin/hdp-select set all `ambari-python-wrap /usr/bin/hdp-select versions | grep ^2.4.0.0-169 | tail -1`' returned 1. Traceback (most recent call last):
  File "/usr/bin/hdp-select", line 379, in <module>
    printVersions()
  File "/usr/bin/hdp-select", line 236, in printVersions
    result[tuple(map(int, versionRegex.split(f)))] = f
ValueError: invalid literal for int() with base 10: 'lib'
ERROR: set command takes 2 parameters, instead of 1


usage: hdp-select [-h] [<command>] [<package>] [<version>]


Set the selected version of HDP.


positional arguments:
  <command>   One of set, status, versions, or packages
  <package>   the package name to set
  <version>   the HDP version to set


optional arguments:
  -h, --help  show this help message and exit
  -r, --rpm-mode  if true checks if there is symlink exists and creates the symlink if it doesn't


Commands:
  set      : set the package to a specified version
  status   : show the version of the package
  versions : show the currently installed versions
  packages : show the individual package names


1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
7 REPLIES 7

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Master Guru

@Roberto Sancho - Looks like some problem with hdp-select installation, could you please try:

Check if hdp-select is installed properly or not ( on the machine where you are trying to install HBase )

rpm -qa|grep hdp-select

If hdp-select is already installed then please make sure that running hdp-select gives correct version

hdp-select

If above command gives wrong version then there is a problem with your upgrade.

avatar
Master Collaborator

Hi:

Many thanks all of you, here is the information:

[root@lnxbig05 bigotes]# rpm -qa|grep hdp-select
hdp-select-2.4.0.0-169.el6.noarch
[root@lnxbig05 bigotes]# hdp-select
accumulo-client - None
accumulo-gc - None
accumulo-master - None
accumulo-monitor - None
accumulo-tablet - None
accumulo-tracer - None
atlas-server - 2.4.0.0-169
falcon-client - 2.4.0.0-169
falcon-server - 2.4.0.0-169
flume-server - 2.4.0.0-169
hadoop-client - 2.4.0.0-169
hadoop-hdfs-datanode - 2.4.0.0-169
hadoop-hdfs-journalnode - 2.4.0.0-169
hadoop-hdfs-namenode - 2.4.0.0-169
hadoop-hdfs-nfs3 - 2.4.0.0-169
hadoop-hdfs-portmap - 2.4.0.0-169
hadoop-hdfs-secondarynamenode - 2.4.0.0-169
hadoop-httpfs - 2.4.0.0-169
hadoop-mapreduce-historyserver - 2.4.0.0-169
hadoop-yarn-nodemanager - 2.4.0.0-169
hadoop-yarn-resourcemanager - 2.4.0.0-169
hadoop-yarn-timelineserver - 2.4.0.0-169
hbase-client - 2.4.0.0-169
hbase-master - 2.4.0.0-169
hbase-regionserver - 2.4.0.0-169
hive-metastore - 2.4.0.0-169
hive-server2 - 2.4.0.0-169
hive-webhcat - 2.4.0.0-169
kafka-broker - 2.4.0.0-169
knox-server - None
mahout-client - None
oozie-client - 2.4.0.0-169
oozie-server - 2.4.0.0-169
phoenix-client - 2.4.0.0-169
phoenix-server - 2.4.0.0-169
ranger-admin - None
ranger-kms - None
ranger-usersync - None
slider-client - 2.4.0.0-169
spark-client - 2.4.0.0-169
spark-historyserver - 2.4.0.0-169
spark-thriftserver - 2.4.0.0-169
sqoop-client - 2.4.0.0-169
sqoop-server - 2.4.0.0-169
storm-client - 2.4.0.0-169
storm-nimbus - 2.4.0.0-169
storm-slider-client - 2.4.0.0-169
storm-supervisor - 2.4.0.0-169
zeppelin-server - None
zookeeper-client - 2.4.0.0-169
zookeeper-server - 2.4.0.0-169


avatar
Master Collaborator

Hi: still the same error

2016-04-12 10:47:22,828 - Checking if need to create versioned conf dir /etc/hadoop/2.4.0.0-169/0
2016-04-12 10:47:22,828 - call['conf-select create-conf-dir --package hadoop --stack-version 2.4.0.0-169 --conf-version 0'] {'logoutput': False, 'sudo': True, 'quiet': False, 'stderr': -1}
2016-04-12 10:47:22,940 - call returned (1, '/etc/hadoop/2.4.0.0-169/0 exist already', '')
2016-04-12 10:47:22,940 - checked_call['conf-select set-conf-dir --package hadoop --stack-version 2.4.0.0-169 --conf-version 0'] {'logoutput': False, 'sudo': True, 'quiet': False}
2016-04-12 10:47:23,232 - checked_call returned (0, '/usr/hdp/2.4.0.0-169/hadoop/conf -> /etc/hadoop/2.4.0.0-169/0')
2016-04-12 10:47:23,233 - Ensuring that hadoop has the correct symlink structure
2016-04-12 10:47:23,233 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2016-04-12 10:47:23,234 - Executing hdp-select set all on 2.4.0.0-169
2016-04-12 10:47:23,234 - Execute['ambari-sudo.sh /usr/bin/hdp-select set all `ambari-python-wrap /usr/bin/hdp-select versions | grep ^2.4.0.0-169 | tail -1`'] {'only_if': 'ls -d /usr/hdp/2.4.0.0-169*'}

How to know if the symlink is ok???

avatar
Master Collaborator

Hi:

When i type this i saw this error, and its the script that ambari is executing to install any client o package, what is happening??

[root@lnxbig05 yum.repos.d]# hdp-select set all on 2.4.0.0-169
ERROR: set command takes 2 parameters, instead of 3


usage: hdp-select [-h] [<command>] [<package>] [<version>]


Set the selected version of HDP.


positional arguments:
  <command>   One of set, status, versions, or packages
  <package>   the package name to set
  <version>   the HDP version to set


optional arguments:
  -h, --help  show this help message and exit
  -r, --rpm-mode  if true checks if there is symlink exists and creates the symlink if it doesn't


Commands:
  set      : set the package to a specified version
  status   : show the version of the package
  versions : show the currently installed versions
  packages : show the individual package names


avatar
Master Collaborator

Hi:

After delete everything into the /usr/hdp directory is working de command now:

[root@lnxbig05 hdp]# hdp-select versions
2.4.0.0-169
[root@lnxbig05 hdp]# ls -lrt
total 24
drwx------   2 root root 16384 Apr  1 12:39 lost+found
drwxr-xr-x  33 root root  4096 Apr  7 09:43 2.4.0.0-169
drwxr-xr-x.  2 root root  4096 Apr 12 11:46 current


Many thanks.

avatar
Master Mentor

@Roberto Sancho please select best answer.