Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

error: service ipc version 9 cannot communicate with client version 4

error: service ipc version 9 cannot communicate with client version 4

New Contributor

when i create a new mapreduce location in eclipse i find this error that mean the

server has newer version, than my client . how i can upgrade hadoop client

6 REPLIES 6

Re: error: service ipc version 9 cannot communicate with client version 4

Mentor

On your eclipse download the version that is on the clustwr. You are correct that it's a version mismatch, I've seen this when trying to distcp between hadoop 1 and 2. Make sure to install locally versions of client identical to cluster. Also download client configs from cluster and place them in your client directory.

Re: error: service ipc version 9 cannot communicate with client version 4

New Contributor

more details please "install locally versions of client identical to cluster. Also download client configs from cluster and place them in your client directory."

i'm newer in hadoop world :D

Re: error: service ipc version 9 cannot communicate with client version 4

Mentor

If your cluster is hadoop 2.7.1 install client jars for 2.7.1 then copy core-site, hdfs-site and mapred-site.XML from cluster and put in conf directory on client. Or save yourself alot of trouble and follow this tutorial https://github.com/hortonworks-gallery/ambari-vnc-service

Re: error: service ipc version 9 cannot communicate with client version 4

New Contributor

my cluster is hadoop 2.6.0 , client jars 2.6.0

i will read more

thank you for you help ^^

Re: error: service ipc version 9 cannot communicate with client version 4

@abdellaoui aicha You can install new clients to match with Hadoop server.

See this and http://hadoop.apache.org/releases.html

Re: error: service ipc version 9 cannot communicate with client version 4

New Contributor

i try this with hadoop 2.6.0 and hadoop-plugin 2.6.0

Don't have an account?
Coming from Hortonworks? Activate your account here