Support Questions

Find answers, ask questions, and share your expertise

error with putelasticsearch

New Contributor

Hi All,

I am using two processes with Nifi which are GetTwitter and putElasticsearch with Nifi:1.7, elasticsearch:6.3.1

Always, when testing, the PutElasticsearch is showing the 'Failed to insert into ElasticSearch' error:

Currnetly, I am using the below configuration for the PutElasticSearch process:

- ElasticSearchHosts:localhost:9300

- Identifier Attribute:uuid

- Index:twitter

And when seeing the elasticsearch log file, I see the error 'Received message from unsupported version: [5.0.0] minimal compatible version is: [5.6.0]'.

I'm asking about the '[5.0.0]', the version of what ?

I will be happy if you can help me on this issue.

Thanks a lot

1 REPLY 1

Super Guru

Are you using PutElasticsearch or PutElasticsearch5? Either way, those processors are bound to specific versions of ES and are not necessarily with (even dot release) differences in ES versions. PutElasticsearchHttp and PutElasticsearchHttpRecord are more robust choices as they use the REST API to conduct ES operations. They tend to be slower than their "native" counterparts but support a wider range of ES versions.