Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

go_live - format version not supported

SOLVED Go to solution

go_live - format version not supported

I have a data flow which uses the MR Morphline JAR. The index creation seems to work fine (the MR job itself reports success), but uploading the new indices (the go_live option) throws an Exception. In the Solr logs, I get the following messages:

 

15:26:09ERRORCoreAdminHandlerERROR executing merge:
15:26:09ERRORSolrCoreorg.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: _2.nv...
15:26:09ERRORSolrDispatchFilternull:org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: ...

 

I've looked about a bit, but I can't seem to find any indication of what might cause this. Is it a problem with my collection configuration?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: go_live - format version not supported

Expert Contributor
Looks like your solr version might be older than what we ship with Cloudera Search. I recommend upgrading to search-1.0.0.

Wolfgang.

4 REPLIES 4

Re: go_live - format version not supported

Expert Contributor
Can you try using --reducers=0 and let us know if the error remains?

Re: go_live - format version not supported

Sorry Wolfgang, I tried running with --reducers=0, but the problem remains: Format version not supported. 

Highlighted

Re: go_live - format version not supported

Expert Contributor
Looks like your solr version might be older than what we ship with Cloudera Search. I recommend upgrading to search-1.0.0.

Wolfgang.

Re: go_live - format version not supported

Just to follow-up, this was my bad: the client had solr-mapreduce from the release yum repo (version 1.0), while the cluster was still on the beta (0.9.3). Once I downgraded my client the merge worked fine.