Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hbase get command throws error in cdh5.0.2

hbase get command throws error in cdh5.0.2

Explorer

We have installed cdh5.0.2 last month. We are trying to run the application on cdh5.0.2 which was running fine on cdh4.2.1 earlier.

It throws the below error as unable to find region.  We have enough regions and all are healthy. Any help on this.

 

2014-08-18 11:46:41,565 INFO  o.rest.connector.RestConnector - Connecting to Hbase Table2014-08-18 11:50:10,779 ERROR tfolio.rest.service.JobService - Exception occurred while getting job summary java.lang.RuntimeExcepti                          on: org.apache.hadoop.hbase.client.NoServerForRegionException: Unable to find region for pcReports,,99999999999999 after 10 tries.2014-08-18 11:52:10,651 ERROR tfolio.rest.service.JobService - Exception occurred while getting job summary java.lang.RuntimeExcepti                          on: org.apache.hadoop.hbase.client.NoServerForRegionException:

 

 

Regards,

Gayatri

3 REPLIES 3

Re: hbase get command throws error in cdh5.0.2

Contributor
It seems the region is not assigned yet. From the master web UI, do you see
this region in transition? Can you scan this table from hbase shell?

Re: hbase get command throws error in cdh5.0.2

Explorer

I'm able to scan the table and even get command works from the shell. But it throws error while calling from rest api.

 

Regards,

GR

Re: hbase get command throws error in cdh5.0.2

Contributor
Any exception in the REST server log? Can you list tables using REST API?