Support Questions
Find answers, ask questions, and share your expertise

hbase org.apache.hadoop.hbase.mapreduce.CopyTable

I am trying below comand to copy data from source to destination cluster with same table name but the job is either failing or after 100% mapreduce completion the mapper still keep on running.

hbase org.apache.hadoop.hbase.mapreduce.CopyTable --peer.adr=server1,server2,server3:2181:/hbase-unsecure AppSummaryVersion


2017-10-12 17:30:07,770 INFO [main] mapreduce.Job: map 0% reduce 0% 2017-10-12 17:35:37,646 INFO [main] mapreduce.Job: Task Id : attempt_1507619332759_0008_m_000000_0, Status : FAILED AttemptID:attempt_1507619332759_0008_m_000000_0 Timed out after 300 secs Container killed by the ApplicationMaster. Container is killed before being launched. 2017-10-12 17:35:49,790 INFO [main] mapreduce.Job: map 100% reduce 0%

Both source and destination server is Hortonworks

Please help me to resolve this issue.


@Sidharth Kumar,

Do you have hbase table with name AppSummaryVersion on your destination cluster?



@Aditya Sirna Yes,i do have a table created even in the destination cluster and i tried others table as well. Increased the memory of yarn container and map and reduce task but still facing the same error.

Tried reverse order as well but nothing worked and job failed with same error. At last for testing i tried running hadoop distcp to copy file from source to destination cluster and it works fine. So if distcp is working fine. What could be the issue. Can you kindly help to resolve this

@Jay Kumar SenSharma Can you help me on this. Please its critical for me


were you able to solve this? I am running into a same issue. Hbase version is 1.2.0.

; ;